• 27000+ Members! Dear Guest, click this link to join the community on the official RaceDepartment Discord server

Activate problem - No response from Reiza :(

jonrarit

10RPM
Nov 30, 2013
14
1
54
I have two machines with two licenced copies of GSC 2013 installed however I am now getting a "fingerprint" error on one saying I have to activate it again but it will not accept the original licence key.

I have emailed "sales@reizastudios.com" 3 times now but have had no reply

Help anyone please?

Jonathan
 

jonrarit

10RPM
Nov 30, 2013
14
1
54
Thanks Andrew but I've tried sending to both sales & support to no avail. I've just resent again (4th) time to support ...... would you be kind enough to please give them a nudge for me?

thanks

jonathan
 

Renato Simioni

Reiza Studios
Jan 6, 2010
1,649
5,246
Hello Jonathan,

Our support response time should be in 48h maximum. If you still havent got a reply, please send us a PM here with your purchase details so we can look into it for you.
 

jonrarit

10RPM
Nov 30, 2013
14
1
54
Hello Jonathan,

Our support response time should be in 48h maximum. If you still havent got a reply, please send us a PM here with your purchase details so we can look into it for you.
Will someone at Reiza PLEASE HELP me with this. I've now sent 2 private messages, 5 emails and forums posts but am getting no help. Please do not let your wonderful sim down with poor customer service.

I am still getting a "fingerprint mismatch" and "invalid activation code" I've tried a clean install to no avail so I either need a new activation code or someway of "wiping" the old licence check.

Come on guys, please get your act together and help out this sim-less racer

Jonathan
 

jonrarit

10RPM
Nov 30, 2013
14
1
54
Many thanks to Renato ...... problem all sorted now and back to just loving GSC :)))

jonathan
 

Connor Caple

Slowest Racer in Town...
Nov 24, 2009
974
355
This 'activation' system is the only reason I have not bought GSCE. I have seen far too many posts on this forum from people having this issue, even for existing, working installs.

I know that companies need some DRM to protect their product, but when it does not operate correctly it just loses sales.
 
  • Like
Reactions: Ho3n3r

Nox

6000RPM
Premium
Jun 29, 2013
6,688
2,331
This 'activation' system is the only reason I have not bought GSCE. I have seen far too many posts on this forum from people having this issue, even for existing, working installs.

I know that companies need some DRM to protect their product, but when it does not operate correctly it just loses sales.
Well, it'll be on Steam soon so problem solved :)
 

Nox

6000RPM
Premium
Jun 29, 2013
6,688
2,331
If they remove their own DRM - which is not always the case with Steam games. That's why some of them have a warning about additional DRM systems.
Well to be fair, I just went and checked the forum and in 6 pages I only saw 3 threads about the issue; it's a small percentage of users who have the issue.
 

William Wester

1000RPM
May 28, 2013
1,270
505
I agree with Andrew, I believe the percentage of those of us that haven't had a license activation problem FAR exceed those that have.

Not buying GSCE because of a few reported activation issue's is like refusing to purchase a car as some have reported getting flat tires :D
 

Quas

1000RPM
May 8, 2012
1,678
823
43
I'd rather walk to Brazil for a good sim than have a crappy one delivered by a Playboy bunny on a golden plate :p.
Never had any problem with activating anything from Reiza either.
 

Kurupt CDN

DirtT Tuned Motorsports
Premium
Jul 18, 2012
2,848
2,255
There's not a game on the market that a few People have not reported a install/startup issue.
And being one of the best racing sims on market for the price, quality and physics it's worth the $25 risk, hopefully your not the 4th :)
 

SwaggerJacker

250RPM
Premium
Jan 10, 2015
436
140
57
I just purchased the sim. My activation code does not work. I emailed support, so I'll be waiting for a reply. Sucks that I may have to wait days to play a game I just purchased. Question....Could it be that I uninstalled the lite version and installed the version from the link from the purchase email received from Reiza before activating? Any help would be appreciated.

Thanks
Steve
 

SwaggerJacker

250RPM
Premium
Jan 10, 2015
436
140
57
Let's see if we can get their attention... @Reiza Studios :whistling:
Jan,
I sent an email to that account before I posted here. I only commented because I've read in several places that sometimes a response is slow to come. If you were just being helpful; then thanks much. If you weren't.....

Fortunately Reiza has responded here. So I'm very happy about that. I'm confident this issue will be resolved soon.
Steve
 

Jan Mikuž

1000RPM
Nov 21, 2013
1,057
174
40
Jan,
I sent an email to that account before I posted here. I only commented because I've read in several places that sometimes a response is slow to come. If you were just being helpful; then thanks much. If you weren't.....
Of course I was being helpful. :)
I tagged them with a "@", which meant they got an alert on their profile pointing them to thread where the tag appeared - it's a Racedepartment function available to all users.