• Welcome to the largest (sim) racing website in the world!
    Blurring the line between real and virtual motorsports.

ACT LABS Force RS steering wheel does not work with Windows 7 or Vista

Discussion in 'Sim Racing Hardware' started by slidejob, Jan 1, 2010.

  1. slidejob


    EDIT UPDATE - I've gotten the wheel working with Windows 7 and Vista! See below...

    Hi all, I've been doing some research into getting the ACT LABS Force RS steering wheel to work with Windows 7 and Vista. It's weird, when you connect it, it installs the driver, and then you can see an icon for it in 'Devices and Printers' under Control Panel, but when you right click on it and go to 'Game Controller Settings', nothing shows up in that box. Hence you can't test it or anything.

    I'm trying to get the wheel to work in rFactor, but it does nothing, no response at all in rFactor's controller config. I've heard of the wheel working in GPL but supposedly that game has it's own controller driver code.

    But, I saw a link from an ebay auction talking about some hacked drivers for this wheel. Unfortunately the link was to RaceSimCentral.com forums, which have crashed.. Does ANYONE have any information about these hacked drivers or info about using the Force RS wheel on Windows 7 or Vista in general? This is such a great wheel, mine is about 10 years old and still going strong. I've done minor maintenance, but this wheel is easy to work on. It's just a shame that something stupid like no new OS driver support would kill it (when so many other BIG BUSINESS companies would continue support but their product is such junk that it falls apart first).

    If anyone knows anything about these supposed HACKED drivers for this wheel, or any info on installing it on Windows 7 or Vista, your input would be greatly appreciated! Thank you.
  2. tac2


    Hi, posted this originally on RaceSimCentral:

    Original post (cached):

    My fix is for 64-bit Windows-7 but it'll be similar for 32-bit or Vista.
    Here's what you need to do:

    Download 64-bit drivers for the Saitek R440.
    (If this URL dies, the main page is here: http://www.saitek.com/uk/down/drivers.php)

    Extract the Saitek_R440_Force_Wheel_SD6_64.exe file somewhere (You might need Winrar to extract the *.exe).

    First you need to find out the hardware id of your steering wheel. Plug it-in, enter Device Manager, ActLabs RS (with a yellow exclamation mark next to it since it's missing its drivers.), Details-tab choose "Hardware IDs". (Mine was: USB\VID_061C&PID_C084&REV_0100 )

    Open the driver *.inf-file i.e. Saitek_R440_Force_Wheel_SD6_64\FF04\SaiFF04.inf

    Look for the title [SAITEK_MODELS.NTamd64]
    Below that there's a line like this:

    Replace everything after %USB_NAME%= SAI_USB_Inst, with your hardware id. This will make Win7 match the driver with your wheel.

    So the end result will be:

    After that, simply double click your Wheel again in device manager. Choose Driver->Update Driver and point Windows to the path where you've got your modified Saitek Driver.

    That's it, you should be ready to go.

    I noticed that one or two buttons including the one looking like a Nintendo-controller in the middle of the wheel didn't work. I guess that that can be fixed too but I didn't bother since I seldom use more than gas/brake/paddles and one or two more extra buttons.
  3. slidejob


    Just wanted to post an update that I've found a Vista and Windows 7 driver for the Act Labs Force RS steering wheel. You can download the driver here:
    Click Here to download the Act Labs Force RS Vista Windows 7 Driver v2.0

    Download the zip, extract it to a folder called 'ForceRS' and follow the Instruction text file included.

    The Force RS is a great wheel and very well built. Mine is still working fine after 10+ years! It would have been a shame to not be able to use the wheel anymore because of a driver problem. But with this fix you can still use the Force RS on the latest operating systems!

    Thanks to JeffInTheUSA. I added Windows 7 support and simplified the fix even more.

  4. slidejob


    Hey guys, the Act-Labs Force RS wheel is now working with both Windows 7 and Vista (32 and 64-Bit)!

    I'm now using my modified Force RS on Windows 7 Ultimate x64. I love the wheel but I found the pedals just don't have enough throw.. So I modded my brothers old Logitech G25 pedals to work with my Force RS. Works great!

    I've updated my driver package to v3.0 (as to not confuse with the original Act-Labs v2.51) and fixed both Windows 7 and Vista 32 and 64-Bit support. I've compiled two Driver packages, one for 32-Bit and one for 64-Bit. Just unzip to a folder called 'ForceRS' and read the installation text file inside.

    Act Labs Force RS Vista-Win7 32-Bit Driver v3.0
    http://pcdoctor.host22.com/Act Labs Force RS Vista-Win7 32-Bit Driver v3.0.zip

    Act Labs Force RS Vista-Win7 64-Bit Driver v3.0
    http://pcdoctor.host22.com/Act Labs Force RS Vista-Win7 64-Bit Driver v3.0.zip

    Installation can be a little tricky when you've already tried using older drivers. Just be sure to follow the installation text files Exactly and it should work fine. I haven't been able to test this new version on a lot of different versions of Windows 7 or Vista, but they should work if you follow the directions exactly. Please let me know if you find any bugs or typos. Thanks and enjoy!

  5. crazyharry


    So.. I got it partially working in Windows 7 64 Bit, but my gas pedal does not give any response in games.

    When calibrating, the bar for the gas pedal does react, but it increases gas over time, not only based on the gas pedal position.
    To make it more clear: When I fully press the gas pedal, the bar shows an increasing amount of gas over time, it's not going to full gas immediately as it should.

    When I start a game and want to setup my wheel for racing, the gas pedal is not registered, so I can not use it.

    If anyone has an idea, I would love to read it.
  6. mclark999


    I was starting from 2 new computers running Windows 7 with no older drivers or anything related. They are both 64 bit versions of Windows 7. I tried installing all three revisions, but get nothing from any of the buttons, wheel, or pedals. Any ideas would be appreciated. I did unplug my keyboard which was the only USB device, so its not a USB conflict.
  7. mclark999


    I was able to get my wheel to work using the files and directions from this forum listing: http://www.racesimulations.com/phpbb/viewtopic.php?p=203104&sid=16440582c8681c9837447889e79bcaeb#203104

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.