• Guest, RaceDepartment is now on Discord!  Join Here
ACC Dedicated Server GUI

Misc ACC Dedicated Server GUI 1.2.5

Log in to download, or make sure to confirm your account via email

HOMEDJCB

1RPM
Feb 27, 2011
8
1
46
Hello,
Thx for the apps but i have the follow problem
I try and runing the server 2 friends enter and is ok
But if i try to enter and i can not see my 2 friends and alone
I see my 2 friends in the lobby
See here
1.jpg


What is the problem
Thx
 
Last edited:

Noiser59

1RPM
Apr 11, 2020
3
1
38
Hello and thanks for your ACC dedicated server GUI :)

I have donwload it and extract in \Steam\steamapps\common\Assetto Corsa Competizione\server

When i launch the .exe i have an error message :

acc1.png

I ignore it and try to launch the server and have this message :
acc2.png


Which could be translate by : the object reference is not define to an instance object

Did i make something wrong ?

Thnaks for your help :)
Noiser
 

Martin Vindis

500RPM
May 2, 2010
619
498
@Noiser59 I suspect one of your json files are incorrectly formatted. Could you upload settings.json, event.json and assistRules.json so I could take a look?
 

Pol Timmer

1RPM
Apr 15, 2020
1
0
21
Hey there, are you planning to make this work for remote server solutions? I currently have my server hosted on an AWS EC2, and would love to use this GUI on my local computer.
 
Apr 2, 2020
2
0
49
Martin...

It appears that the GUI is modifying all .json files except for configuration.json. Is this right or do I have something screwy on my end?
 

Martin Vindis

500RPM
May 2, 2010
619
498
Martin...

It appears that the GUI is modifying all .json files except for configuration.json. Is this right or do I have something screwy on my end?
As configuration.json only contains ports and max clients options (afaik) I didn't bother to add it as it's mostly just set and forget options for most people. Will be added in a later update.
 

Pas Mon

1RPM
Sep 27, 2019
2
0
61
hello I install the software but by clicking on the start button, I do not have the opening and display of the Windows command prompt and therefore the software does not work. do you have a solution i'm running windows 10 pro.
 

Martin Vindis

500RPM
May 2, 2010
619
498
hello I install the software but by clicking on the start button, I do not have the opening and display of the Windows command prompt and therefore the software does not work. do you have a solution i'm running windows 10 pro.
Not sure what it could be. Can you start the server without this tool? Try running it with admin rights.
 

Pas Mon

1RPM
Sep 27, 2019
2
0
61
hello Martin, thank you for the speed of the return,
my concern is settled. It was just that I had scheduled the race, now I have scheduled the race and qualification and everything is working perfectly.
HOWEVER I launch the ACC application finds the server and I can drive, however my friends see the server perfectly on ACC but cannot join the server and the race. thank you for returning to resolve this concern. amicably
 

Martin Vindis

500RPM
May 2, 2010
619
498
same problem here , ports 9231-9232 already set but server shows no ping "- -" and people cannot get in. did i miss HTTP port ?
I had this issue as well so I removed the ports in my router and added them again which for whatever reason fixed the problem. Not sure if this would work for you but seeing the server with no ping is a clear indication of something blocking it, wither windows firewall or something messed up in the router.
 

T1M40

1RPM
May 24, 2014
4
0
43
possibly the same cuz my ISP modem is not so good, im gonna reset the rules, thanks for the answer