AC will NOT remember settings

Discussion in 'Assetto Corsa' started by Piero Favretti, Jun 22, 2018.

  1. Piero Favretti

    Piero Favretti
    Premium

    Messages:
    256
    Ratings:
    +171
    Hello

    I will try to be brief, forgive me is I seem frustrated but I am, very much so, and have been since Assetto Corsa came out.

    The short of it is; if I play AC on a daily basis the game seems to remember my settings. If I don't use it for a period of time once I log in EVERYTHING IS GONE!

    I have read I am not the only one having this issue, now on 2 different PCs, in Windows 7 and Windows 10. I have tried everything and every suggestion on the internet, yet this incredibly irritating and time consuming issue persists.

    Can someone please point to a solution? Otherwise I will permanently uninstall this SIM and be done with it. Please understand I have an AccuForce wheel, AC does not (in my opinion) have the best FFB out there, getting it to feel right with the AccuForce is a time consuming process. Yes, I have the settings saved in the SimCommander software, curiously when AC loses it's internal settings it never feels the same way so I have to go tweak this or tweak that.

    Again, if I seem unreasonable or hard on AC please understand this is an issue I have dealt with since it came out and I have wasted enough time on a no brainier issue the game should not have. By the way, AC is the ONLY game having this issue even when no new updates or patches have come out.

    Any helpful feedback to permanently resolve this issue is appreciated. Thank you!

    PS; I forgot to mention when this happens, after a period without usage, the game acts as if I just installed it, even my saved replays are gone...everything is gone except for my profile curiously.
     
    Last edited: Jun 22, 2018
  2. TheMixon

    TheMixon

    Messages:
    3
    Ratings:
    +5
    For me AC is very touchy about how I connect my wheel, for example. I have to do it the same way, same USB ports (used to be a problem, now I just connect everything to a dongle). If I run the game just to check something without having my wheel connected, it deletes all the settings. Basically I have to steer clear of anything related to steering, or else AC will delete everything.

    I don't do much but assigning pedals and stuff, but it deters me from trying to go in-depth. Also yeah, it seems that when AC is in doubt, it wipes everything.

    It pains me greatly, as no other game has ever done something like that.
     
    • Like Like x 1
  3. Jempy

    Jempy
    Premium

    Messages:
    997
    Ratings:
    +275
    I never encountered this problem and never heard of it for other ones ( and I was and am rather present in many forums since the very beginning of AC ).

    I just wonder why this might happen.... there must be something in common in the PC configs for those rare ones having this kind of problem.

    I now have a SSD for +- 1 year .... but all simracing games including Steam are on my SSHD ... and my Documents also, the SSD with only Win10 and most softwares except games.

    Might it only be a problem due to the way your PC is configured with SSD-HDD-Documents-Windows ?? ... or Administrator rights ? .... or maybe a conflict with a used software or even antivirus suite ? .... I don't know why but I should search first for a problem there.

    The best should be that you might compare your configs with others with the same problem.
     
    • Like Like x 1
  4. Kek700

    Kek700
    Premium

    Messages:
    541
    Ratings:
    +244
    I do not use sim commander I just use
    the settings stored in the accuforce wheel.
    All I ever did was endlessly fiddle with the settings.
    I find using just wheel settings and settings
    In AC provides a very good results.
    When setting have been made in AC,save them to your setting in ac ( example accuf1)
    Never had your problem unless I did not save in AC.
    There is in my view only one sim that has better FFB and that is ractor2. AC is very close.
     
    • Like Like x 1
  5. Piero Favretti

    Piero Favretti
    Premium

    Messages:
    256
    Ratings:
    +171
    Thanks for the feedback guys.
    @Kek700 SimCommander is not the issue, the issue is AC itself. How can it lose all saved settings? How can it lose all the saved replay files?

    @Jempy I run all the games and software as administrator, I do have all the games saved on a HD other than my boot SSD drive. How can settings be fine if I use the SIM or twice a week, suddenly gone if I don't play it for 2-3 weeks?

    @TheMixon You would think a fix would have been applied long ago for the settings disappearing. I get how people enjoy AC when it's running perfectly, but this kind of bugginess has me pulling my hair and wanting to delete it all together.

    I don't get why these issues only affect a handful of people, I wish I could find a permanent solution and/or for Kunos to FIX this once and for all.
     
  6. Kek700

    Kek700
    Premium

    Messages:
    541
    Ratings:
    +244
    Go into steam and do an integrity check on AC
    and see if any of AC is corrupted.

    My pc runs entirely from a SSD.

    You could start from the position of copying
    my process, and mimicking my system approach as it is similar to yours,
    Load setting to accuforce wheel itself, not using all the variables from simcommander4 , shut
    Simcommander4 down, start AC ( not from sim commander ) adjust AC parameters, for steering and pedals ,then save settings and see if it is saved permanently

    All I do is turn on pc, accuforce goes though
    It’s initiation, load AC, and I then always go straight into race mode.:)
     
    • Like Like x 1
  7. Kek700

    Kek700
    Premium

    Messages:
    541
    Ratings:
    +244
    Don’t forget to set AC wheel rotation to match
    accuforce wheel rotation, I always use 540 degrees as an example.
     
    • Like Like x 1
  8. Piero Favretti

    Piero Favretti
    Premium

    Messages:
    256
    Ratings:
    +171
    Thank you for the suggestion Kek700, I will give it a try and report back.
     
  9. Mascot

    Mascot
    Card-carrying mod whore Premium

    Messages:
    974
    Ratings:
    +301
    Are you using the default Kunos launcher? If so, try Content Manager. You can save and edit multiple profiles easily.
     
    • Like Like x 1
  10. Brun

    Brun

    Messages:
    121
    Ratings:
    +526
    Controller assignment is simply based on the order in which devices appear in Windows Game Controllers control panel. Any changes to this and it's very likely the configuration will be lost.

    It was probably done like this initially because it's the easiest way, and works well enough if - for example - you're using a Thrustmaster setup where wheel, pedals and shifter are all see as one device (and don't regularly connect and disconnect other things like gamepads). However it's absolutely terrible when using hardware which is seen independently. Kunos were no doubt aware of this at some stage but a solution was clearly never considered a priority.

    Mascot's suggestion of Content Manager is worth following. I think (not 100% sure) that it doesn't suffer from this problem.
     
    • Like Like x 1
  11. Pawel Ziolkowski

    Pawel Ziolkowski

    Messages:
    185
    Ratings:
    +53
    Don't think that's how it works. I have been disabling (in registry), unplugging, hotswapping, etc. many different devices including virtual and DIY hardware and AC always remembered what was doing what.

    I suspect it's the windows dropping and assigning new ID's to the hardware that's causing an issue and that probably has something to do with how it manages it's drivers.

    Not saying it's not possible to do it right, other sims can do it, but i think it's because the devs there went the extra mile to fix whatever mess the windows makes, and it's not easy to even know the full range of possibilities of how it can fail, let alone design around it.
     
    • Like Like x 1
  12. Brun

    Brun

    Messages:
    121
    Ratings:
    +526
    Posts from
    It's exactly how it works. See here.
     
    • Like Like x 1
    • Agree Agree x 1
  13. TheMixon

    TheMixon

    Messages:
    3
    Ratings:
    +5
    I suspect something along the lines of what Brun wrote. After my settings are wiped, I usually find everything assigned to the shifter for some reason.
    I'll try to do it in CM next time it happens.

    Edit: Jesus, do I see right? Are those posts from 2016? It's impressive Kunos managed to produce such a good product and then completely disregard bug fixes. Not to mention stuff like the VR UI being awful.
     
    Last edited: Jul 4, 2018
    • Like Like x 1
  14. Piero Favretti

    Piero Favretti
    Premium

    Messages:
    256
    Ratings:
    +171
    All, thank you replying. I have saved controller settings every time in between everything disappearing. Remember that all my replays vanish. This is an issue not limited to the controller settings, it's as if I did a new install.
     
  15. Jempy

    Jempy
    Premium

    Messages:
    997
    Ratings:
    +275
    After reading this USB bug for AC, I may understand the problem with the controller settings .... but also replays vanishing seems to point to another problem in your case.

    Did you check that other files in your Documents are not also disappearing ?
    The fact you mentioned that it happened only after a longer period not playing AC .... makes me think it should be good to check other documents in your PC.

    I already heard about a virus deleting some files after a certain amount of time.
     
    • Like Like x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.