33 km RBR track

Brendon Pywell

Bob's Track Builder
Feb 26, 2009
418
156
UPDATE: NEW 1.2 VERSION - The new update adds more variety to the terrain, much more grass, more surrounfing trees and SObjects were used to add the fencing & telegraph poles. Some textures were also updated. Enjoy!!

Sorry to anyone else who is gettng sore eyes from not blinking whilst playing. I have tested this track numerous times and after 3 days now have eyes that just won't stay open any longer. Long tracks are welcome, but take care and get some good rest in beteween. ;)

Description
============

As a test of the new RBR plugin I created a very rough track and covered it on objects. It's not the best design, not the prettiest, but a great proof of concept and I thought I'd share it with you as a taste of things to come with BTB v0.7.

Requires a high end graphics card capable of Instancing (typically SM3.0 onwards).



Stats:
- It's 33kms long.
- took less than 3 days to build, including the coding of a new BTB planter tool.
- takes about 26 minutes to drive with a few stops along the way to hug a tree.
- contains ~25,000 trees, a mixture of the new complex ones and some regular ones.
- over 250,000 objects.

On my machine it:
- loads in < 21 seconds.
- the new LOD system keeps the frame rate @60fps at 1920x1200 (running without Car Reflections)

No I don't need any feedback on how to improve the track - it's just a test. ;)

Disclaimer
============
This track has been made in under two days and as a test is not completed to it's full potential.
- There are no pacenotes because I don't have time.
- There is no camber because I don't have time so you will slipp off.
- There are no retaining walls because I don't have time; stray more than 20 meters from the edge of the road and you risk falling to infinity.
- The plugin is not compatible with previous versions of plugins - do not attemtp to run older tracks using this plugin. Note the current copy of BTB will, during export, overwrite the plugin automatically.

Credits
============
- black f - one plugin
- Brendon Pywell - one track
 

Attachments

eno72

100RPM
Mar 16, 2009
121
10
simply amazing, and a big surprise (and relief) for all people here around worried about performance on long and crowded stages! :Banane27:
Now downloading, can't wait to try and report on that
 

jay_p_666

100RPM
Mar 21, 2009
200
2
Oh ****, that is actually crazy proof of concept...

Thanks to you both, this is truely awesome!:yo:
 

Gareth Hickling

2000RPM
Feb 17, 2008
2,864
2
41
As ive just got back into RBR I will give this a try, It may even perswade me to grab a full copy of BTB. :dance2:
 
4

42Cliff

yup, tarmac tires here too, also got a error loading the fx on the loading screen, load time was 32seconds so that's good!

unf for me the framerate is very low even at 640x480, but that's my vid card most likely ..

amd4200+ 2gb, 6600gt (128mb I beleive)

but, that said, it's far better than I could get with a similar length track and far fewer objects w/the old plugin

The new trees are looking good too!

edit:
version ok.
LoadTextures()
LoadEffects()
LoadEffect() : error in RX_CONTENT\COMMON\FX\shadowvolume.fx
LoadMaterials()
LoadMeshes()
LoadGeometry()
LoadEvents()
LoadDriveLine()
LoadSpawn()
ColSplit()
ready ...
loading time 32953ms.
edit2:
My bad, I just removed the old rxcontent before installing, so I didn't have the common folder, so no problem!! Just had to copy it over.
 
S

Steely69

Thanks for the tyres, seems to have knocked a bit off the fps. Was around 60 now 40 and under.
 
J

jharro

Thanks for the tyres, seems to have knocked a bit off the fps. Was around 60 now 40 and under.
not the tyres, the car reflections are most probably cause FPS drop, as Piddy mentioned they are enabled in the patch but if you want to turn them off set:
UseCubicEnvironmentMaps = false
in RichardBurnsRally.ini.
we'll most probably turn them off again after this test until we'll get enough FPS to afford them.
 
4

42Cliff

UseCubicEnvironmentMaps = false

it worked for me, that and turning everything to low .. its still low FPS for me, but I expect it..

the one thing I noticed on this though is that about half way through the FPS drops dramaticly, and does not come back up if I turn around and go over the same first half again ...

I think something similar happened before too, cause at the end of the pikes peak test it was also really choppy - I thought at that time it was because I was higher and could see more track, but I never tried turning around like I did this time.

so are things getting loaded into some memory but not cleared out? I've only got 128mb vid mem, so maybe that?

also, If there was a option to set the max visible distance I'd possibly be able to drive with a good framerate .. its close now at lowest everything... :)

Really love the trees BTW :) and the first third I can tell would be wicked fun with the great FPS you guys can get on newer hardware! :)
 
4

42Cliff

Steely, is your ini set to read only maybe? or are you starting from the launcher instead of running RichardBurnsRally_SSE.exe directly?
 
S

Steely69

Yep, my bad. Works fine. Have a couple of batch files which swap the ini's depending if I run full screen or not. Derr..