1967 Watkins Glen

James Bunn

25RPM
Jan 9, 2020
36
18
50
Still having problems, anyone know a way of debugging this? Most added circuits work fine but a couple cause a CTD and you cannot restart the game until you have removed the track folder which is causing the problem from the locations directory forcing GTL to reset the track selection.
 

chrisracer

25RPM
Dec 31, 2016
38
48
68
I have had this happen on several occasions. First thing I tried was running the track in practice mode. If it works for practice mode what is happening is the track is takeing up too much memory. Try reducing the field. Are you using the core tool? I started using it and I am not having any issues with slow downs, stuttering or tracks crashing.
 

James Bunn

25RPM
Jan 9, 2020
36
18
50
I doubt that the tracks are taking too much out of my machine, Its an AMD ryzen 7 3700 8 Core CPU with 16Gb ram and a Geforce RTX 2070 with 8 Gb, but I will try the core tool, what is that though?
 

James Bunn

25RPM
Jan 9, 2020
36
18
50
The Process Lasso? Yes I have been using that. No luck so far, Brand Hatch, Cadwell, LeMans and Monaco are all working fine, its just these two tracks that are causing a problem. I would especially like to get Targa working.....
 

GTR233

500RPM
Jun 3, 2018
648
467
For big tracks and also big car mods it is mandatory to patch your GTL.EXE (same for GTR2.EXE) with 4GB PATCH by DANIEL PISTELLI.
Note that your EXE is already 4GB patched if you have installed the GTL or GTR2 10th Anniversary Patch :)
 

James Bunn

25RPM
Jan 9, 2020
36
18
50
OK, I have already installed the 1oth anniversary patch and then did the 4Gb patch after as I had not realised it was included. This has not helped on GTL and I still have the problem however on P&G3.2 with the GTR2 exe 4gb patched Targa now works. Great for P&G but not GTL. Wish I could find a solution to this.
 

GTR233

500RPM
Jun 3, 2018
648
467
I have made a lighter Targa version for both GTR2/GTL, as GTR2 works for you then I give you the link for GTL :
Hope it will work for you :)
 

James Bunn

25RPM
Jan 9, 2020
36
18
50
Sorry, no change, splash screen comes up for a second as the track starts to load and then CTD. I have a bit of a monster machine for running GTL so surprised if its the 2-4Gb thing, I really appreciate all your help BTW.

Machine is: AMD Ryzen 7 3700 8 Core CPU with 16Gb ram and a Geforce RTX 2070 with 8 Gb
Although process lasso reports 15 cores. I trimmed that down to 8 in process lasso as well just in case but that made no difference. I only have the problem with Targa and Watkins Glen, I am sure it would happen with others but I have not downloaded that many.

LeMans LM 77 and 79 are fine and they are quite chunky tracks and all the others I have downloaded are fine as well.
 

philrob

25RPM
Aug 18, 2009
31
16
James,
i have not ran GTL for many years but i spotted your post.And as i had worked on this track for RF1 many years ago it made me interested.
I loaded GTL and Watkins and it worked. I would look again at the install or perhaps the down load. my specs Win10, 970 GFX, 16gb, i7 (no patch )
I know this is not an answer but perhaps an incentive to try afresh.
 

James Bunn

25RPM
Jan 9, 2020
36
18
50
Hello Philrob, thanks for that, I have appreciated MANY of your tracks over the years and in No Grip days. I will download the tracks again from scratch and see what happens.
 

Nickel20

1RPM
Jul 18, 2018
2
0
66
Hi There
It's a great period track, and works for me, but I downloaded ages ago. Have you run a trace file?
A error in a car file can cause a track to crash.
Cheers
 

umma gumma

25RPM
Jan 14, 2019
26
18
77
there was a script someone made called "GDBrename.exe" that was commonly run in a batch file before GTL.exe started

I believe it fixed some upper/lower case names & extensions, maybe even permissions? in the GTL install, that could cause instability like this

I just searched online & couldn't find it though

if it's any use, I can zip up my version & upload here
 

umma gumma

25RPM
Jan 14, 2019
26
18
77
just uploaded it, try this:

 

James Bunn

25RPM
Jan 9, 2020
36
18
50
No luck so far, downloaded it fresh and installed it again, same thing, it crashes right after a flash of the loading splash screen with the GTO on it. Nickel20, how do I run a trace file? I tried changing cars in case that was the problem but no. I was only running the Lotus Cortina which I had been using on may other circuits anyway.
 

Nickel20

1RPM
Jul 18, 2018
2
0
66
Edit Target in Properties Shortcut Tab in your Desktop Shortcut
Best I show an example for one of my game version
"C:\Games\GTR2 Trans Am 1968 - 1971\GTR2.exe" -trace=1000
The results will be shown in the Game/UserData/Log file.
 

GTR233

500RPM
Jun 3, 2018
648
467
If you have 10th Anniversary Patch then the trace function can be enabled by running DEBUG.BAT file, after any CTD go to UserData\Log directory then open trace.txt and look at the bottom lines of this text file :)
 

James Bunn

25RPM
Jan 9, 2020
36
18
50
Ah OK will have a look, Many thanks guys I do appreciate it. Just did a youtube on P&G at Targa with the 427 Cobra, would like to compare with GTL. Lots of crashes as I don't know the circuit and at 44 mile it will take a while but good fun none the less.