1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XPacker - texture scale

Discussion in 'Bob's Track Builder' started by Alex Kyriak, Apr 17, 2010.

  1. Hi all - in Xpacker, when I assign a texture to a material on an imported 3ds model, the texture does not fit the surface its mapped to. I have tried scaling, offsetting and rotating the texture but it seems to have no effect when the XPack is reloaded. Any ideas? :)

    Edit : I'm using jpgs. I can use dds if required, the everything seems to work fine with the jpgs - apart from the mapping problem above.
  2. It depends on how your 3ds model has been constructed.
    The texture needs to be UV mapped in the 3D program so that Xpacker knows where it should go.
  3. thanks eric. managed to solve that now with your pointer.

    Here's another question: I am trialling MAX 2011, I have imported a model from Rhino (a 3d/cad app) into max, given every surface a texture, exported as a 3ds, loaded it into XPacker, everything appears in BTB, but when its tested in RFactor only some of the faces appear - some are invisible. Is this somthing to do with normals? Or with textures or mapping not being assigned properly? not quite sure how to determine what the problem is.
  4. Make sure all the normals are pointing outwards. Faces have a front and a back (determined by the direction of the normals), and the back of a face won't be shown by default. Before spending time messing with the model, in BTB go to venue materials, find the material(s) of your object, and select the 'double sided' option, export and see how things look in rFactor. If it looks fine, you'll know it is a normals issue, but bear in mind that you've now doubled the polycount of the object, so you'll still need to sort it out properly in 3dsmax.
  5. Soul - that's the ticket, thanks. I checked all the normals, made them point out and all appears in RF. Cheers.

    Now to get the textures looking right!
  6. Eric thanks alot - will give it a read tonight.