1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC X1 Controller too sensitieve after 1.9.1

Discussion in 'Assetto Corsa' started by Friso_ffm, Oct 26, 2016.

  1. --Issues fixed in 1.9.2 update "Improved Speed Sensitivity calculations for X360 Game Pad controls (good default is now 50% Speed Sensitivity)"

    After the release of 1.9 (with DLC and latest 1.9.1) I immediately noticed that the steering was much more sensitieve on my Xbox 1 controller. When going slow it is manageable but at speed it flings the steering wheel from left to right with great speed.

    Maybe something had updated or changed in 1.9 so I took my time to re-calibrate today but no real improvement. It's still is way to twitchy.

    It looks like Speed Sensitivity and Steering Speed don't make much off an impact after release. Gamma and Filter do, but that won't fix it.

    Does anyone else have the same feeling??

    Side note: before anyone says "Get a wheel", I have one (G27) but I still like to use the controller for random pick up and play.
     
    Last edited: Oct 28, 2016
  2. Increase the speed sensitivity (like 70% for e.g), that will prevent the steering wheel from flinging easily at high speed. You can test that at 0 or 10% is easy to move at high speed and at 100% is heavily locked from moving too much.
     
  3. Changed it, changed something more and after a few tries got a working setup again. Wierd.

    It's probably me just over correcting the settings and trying them long enough.

    It's now

    Speed Sensitivity 90
    Steering Speed 45
    Gamma 1.5
    Filter 0.1
    Deadzone 0

    Which is not the same as it used to be, but works for me.
     
  4. jlnprssnr

    jlnprssnr
    Premium Member

    1.9.2 fixes 360 controller sensitivity:

    "Improved Speed Sensitivity calculations for X360 Game Pad controls (good default is now 50% Speed Sensitivity)"
     
    • Like Like x 1
  5. No way, I was right xD

    Now I have to re-calibrate again, but this is good news. Thanks for the information.