1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wrong track lenght and off timing when exporting

Discussion in 'Bob's Track Builder' started by rdmgarcia, Aug 26, 2010.

  1. Well,

    After 12 hours of work, I have created a version of my first track where the car can actually race smoothly on it. But I have found a couple of things....

    The virtual track is faster!!! Real life track record is about 41 secs for the kart and category I'm running. My time on the virtual track was about 36 secs and dropping! I wonder how can that be.

    One lead to solve this issue may be that the track lenght reported on rfactor is 0.1 km which is way less of the .83 km that the track has in real life and in btb...

    Any ideas?
    I'm using a demo license
  2. The physics of the karting mod might be off, allowing you to take corners more quickly than usual, or giving the kart better acceleration. Similarly, there's more to making an accurate track than the layout and gradients. You can also change how much grip the materials have. In your track folder there will be a .tdf file where you can set various properties of materials. e.g. RoadDryGrip=1.00 is the default setting, but you could reduce it. Bear in mind that when you export your track, that file will be reset if you select the 'overwrite tdf file' option.

  3. Thanks a bunch for your quick!

    I trust the physics of the mod. Other tracks that have been created are spot on... I was reading a little bit more (something I should have done before asking :) and it seems that this guy has had the same problems http://www.racedepartment.com/bobs-track-builder/37161-circuit-information-other-silly-things.html

    Since I see the track lenght of 0.1 km on his display as well, I am thinking that that's a generic that doesn't actually represent the real value of the track lenght. Also, I think I'm going to play with the speed values on the .gdb file. I wonder if I'm on the right way though :)
  4. The 0.1 km track length shown in rFactor is just the default set by BTB. You have to open the gdb file and enter the correct length manually in the line ' Length = 0.10 km'. The same goes for the location.

    This file will also be reset if you select the 'overwrite gdb file' option.
  5. A question on the tdf file.
    Will switching settings in the file effect other tracks or only the track you are creating?
    Do you need to change the setting before you create the track or can it be done during the process?
  6. Erwin Greven

    Erwin Greven
    Premium Member

    it effects only the track you are building at that moment.
    Changing the settings can be done while building the track.
  7. Proberly overhere offtopic but don't trust the overwriting files settings !
    I noticed that even when you disable the "Clear folder" and don't want to overwrite gdb,aiw,cam files. Every time again it's overwritten!
    So keep a good correct copy of those files.
    Every time again, after export, I have to change my gdb file manual, grrr.
    The same with tdf ?