1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows 7 = Game Won't Start

Discussion in 'ARCA Sim Racing' started by Dustin Barton, Dec 10, 2009.

  1. I upgraded from Vista to Windows 7 and ARCA won't start now. I've heard reports that I have to deauthorize the game or something? A little help would be appreciated :)
  2. What "Leverage" you have? Version 2?
    What windows 7? 32 or 64?
    If you can, its better not upgrade. Do a fresh install. Is faster and more stable.

    Do a directory backup (for not losing you setups).

    You can ask for a new token.

    Try to uninstall and install again.

    Sorry my English
  3. I tried randomly starting the game today and it worked. Says I have to register the game again, but it's just nice to see that it's working :D Downloading the update, then the new track and hi-res skin pack.
  4. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    So you are good to go? Works fine here with Win 7...
  5. It seems so. I did an upgrade rather than a fresh install because I'm waiting to reformat until I get an SSD (sometime soon?). The game wouldn't start/load after I upgrade to Windows 7 but now it is...weird. I pretty much set every .exe file in the folder to Run as Administrator and put it in compatibility mode with Windows Vista and nothing worked, but now, voila! Anyway, where can I download the new track? Or was it part of the update?
  6. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    Charlotte should be in the last update yes :thumb:
  7. I thought so (saw 'Charlotte' pop up during the patch install) though I'm not seeing it for some reason. Perhaps I need to restart the client?
  8. it is called Concorde in the game :wink:
  9. Lol, you know, I thought that might have been the case but I figured 'no one calls it that anymore...' :p