1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

When wiill Stock Car Extreme work on Windows 10?

Discussion in 'Stock Car Extreme' started by mrcds, Jul 29, 2015.

  1. Hi, I have today updated my PC to Windows 10 and I had the bad surprise that the game won't launch. I saw on another thread that SCE isn't compatible with the OS, but will it ever be ? And as I think it is likely to be upgraded, when will it be ?
     
  2. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios Premium Member

    There isn't any reason that I'm aware of as to why it shouldn't work... Someone just posted that the beta works fine... I don't have W10 yet tho to test myself.
     
  3. Oh I just did an integrity check on Steam and it works again ! Sorry for the inconveniance :)
     
    • Like Like x 1
  4. They game runs, but i have poor performance. Whats going wrong?
    My Graphig Cards have Usage to max 60% and my CPU Usage max 55%,
    but my Frames go down to 54 FPS. At WIndows 8.1 i have 80 - 120 FPS in
    ever Scene.

    Hmmm?
     
  5. Are your Graphic Drivers up-to-date ?
     
  6. yes, complete clean, 353.30 Win10
     
  7. I've been part of the Windows 10 Insider program and never had a problem with this game. Or any other. Quite the opposite. I find all the games I have run better if anything.
     
    • Agree Agree x 2
  8. PieterN

    PieterN
    Premium Member

    I'm still running Win 7. What do you mean by better ? Could you elaborate a bit ?
     
  9. Kurt Vanhee

    Kurt Vanhee
    Premium Member

    Must say that everything runs fine Windows10.
    Even got a nice boost in FPS running in multiview;)
     
  10. Dave R

    Dave R
    Premium Member

    I installed it yesterday and after about an hour or so, went back to Windows 7. When I tried to play SCE, it kept throwing an alert up in the bottom right hand corner telling me that SCE was trying to use the graphics card, well no sh@@ Sherlock. Couple that with the fact that NR2003 and Tiger Woods couldn't be played on W10, and Assetto Corsa and R3E had HUGE frame rate drops and I went back.
     
  11. Gained about 5-10fps moving to Windows 10.
     
    • Agree Agree x 3
  12. Everything perfectly fine here. Even very old sims like GPL, which is older than NR2003, run lovely.
    I agree, fps increase here too but nothing dramatic from Win8.1. From 1 to 5 fps depending on the game
     
    • Agree Agree x 1
  13. Works perfectly here on 10162 and every other version/driver combo I tested.

    w10 snuck the default drivers back onto my system again and I didn't even notice, thought I was still running 15.7 ;)

    Performance uplift in every title so far, including GSCE
     
    Last edited: Jul 31, 2015
  14. hex

    hex

    I did clean install with Windows 10 on my PC, so I had to reinstall the game due to d3dx9_30/d3dx9_40 issue (which was not fixed by installing DirectX nor by manually placing the files).

    Now it's all good :)
     
  15. trillbo

    trillbo
    Premium Member

    I'm getting random spikes in framerate in Windows 10 in beta and standard versions, very noticeable on the pit straight and some corners in Taruma. Very distracting! I have a Titan X and latest drivers, so this shouldn't really be an issue. Anyone else seeing this?

    EDIT: I set Opponent Detail to low and it seemed to fix this. Just thought I'd mention in case somebody else is having the same issue!
     
    Last edited: Jul 31, 2015
    • Agree Agree x 1
  16. Upgrade to Windows 10 was seamless.
    GSCE runs fine on my system.
     
  17. Msportdan

    Msportdan
    @ Simberia @Simberia

    I'm getting the micro stuttering too. before I was well happy with GSC perf, now I'm not... tried turning off shadows a time scale doesn't really cure it, SV8 at imola at certain time of evening 30fps!!! 18 cars

    AC for me is running a dream, almost full whack @60fps (bar ultra reflections)
     
  18. Possible tweaks

    Check your config.ini file and see if it has settings that reflect your computer and video card's RAM properly:

    CPURating=5
    SystemRAM=8192
    VideoRAM=4096
    ObjDetail=5
    TexDetail=5

    Also in SCE Config util leave the Shader Level on Auto instead of DX9.