1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wheel disconnecting when exiting rig

Discussion in 'Sim Racing Hardware' started by Noel Spence, Oct 31, 2016.

  1. Noel Spence

    Noel Spence
    Premium

    Messages:
    945
    Ratings:
    +231
    hi chaps i have a problem with my clubsport wheel disconnecting as soon as i try too get out of my rig ,it happens in all sims ,anyone else have this odd behaviour , it is getting to be a bit of a pain ,i am on w7 64, it is fine when i am driving
     
  2. Moxley6969

    Moxley6969

    Messages:
    524
    Ratings:
    +206
    Static can be a Bit*h of a thing to diagnose....try touching somewhere different before exiting the rig. Or try some Static guard on the seat. Is your household less humid or Dryer than normal ?
     
  3. Noel Spence

    Noel Spence
    Premium

    Messages:
    945
    Ratings:
    +231
    yeah cheers mate i thought it could be that ,as the wheel runs fine otherwise, until i go to step out,also the rig is near the kitchen
     
  4. Noel Spence

    Noel Spence
    Premium

    Messages:
    945
    Ratings:
    +231
    i have an electric jaffle plugged in just behind the rig ,i touched it before i got out of the rig and looks like it might of solved it ,cheers again
     
    • Like Like x 1
  5. Moxley6969

    Moxley6969

    Messages:
    524
    Ratings:
    +206
    I had a little bout of Static shutting down my Motion controllers. For a few days it seemed to be really bad, then sorta disappeared.....Im guessing it was the humidity in the house adding to the problem. I also discovered i Could touch my CF/Aluminum adjustable wheel deck and discharge myself.
     
  6. Noel Spence

    Noel Spence
    Premium

    Messages:
    945
    Ratings:
    +231
    :thumbsup: