1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
MINI Challenge - Round 1 - Oulton Park (LIVE)

What the hell is up with my PC? My cars run at triple speed!

Discussion in 'iRacing' started by Adam Bark, Jul 6, 2011.

  1. I just replaced my old corrupt harddrive with a new 2TB one the other day and am now using a 32 bit version of Windows 7 and now when I've had my PC running for a couple of hours, all of my games run at ridiculous speeds. Also another thing when I'm on iRacing, when it is running at normal speed, on oval circuits I get weird lag where the car slows down slightly then a frame flicks up and I continue.

    Another thing I should mention that I've done differently this time is download my graphics driver from the Nvidia website as I lost my driver discs too. Can anyone help? I have no idea why its doing it.
     
  2. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Adam, your frame flickering n lag has to do with 3 things, CPU, GPU and RAM.
     
  3. Yeah. Its really weird though because before my corrupt harddrive everything was running brilliantly. I only have 2GB ram (my other slot broke otherwise I could have 4gb) but everything ran great on full quality with rFactor and iRacing.
     
  4. Regardless of what OS you owned previously please do not talk about cracked versions of OS at RD, it could land you and RD in trouble.
     
  5. If you had downloaded the newest drivers from Nvidia that may very well be your problem. I had to roll back to the 270.61 drivers because the newest which were the 275.33 drivers made iRacing unplayable to me...
     
  6. same here, roll back drivers and it fixed :)