• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

VR not working since last update

Discussion in 'rFactor 2' started by Cote Dazur, Oct 31, 2017.

  1. Cote Dazur

    Cote Dazur

    Messages:
    673
    Ratings:
    +349
    I tried to launch RF2 this afternoon, same as before, but this time VR is not launching. What do I need different now. :(
     
  2. MarcG

    MarcG
    Premium

    Messages:
    712
    Ratings:
    +270
    - Check that you've selected 1109 in the Beta Drop down box
    - You have No plugins (that write to screen)
    - Have you updated to latest Windows 10 Fall Creators Update? As this is causing a lot of problems across a wide range of games so could be that
     
  3. Cote Dazur

    Cote Dazur

    Messages:
    673
    Ratings:
    +349
    @MarcG 1109, yes, no issue anywhere else with the latest Windows 10 Fall Creators Update,
    Plugins that write to screen, I have no idea what you are saying.

    in red in the steamVR box it says : (unresponsive) rFactor2.exe
     
    Last edited: Oct 31, 2017
  4. MarcG

    MarcG
    Premium

    Messages:
    712
    Ratings:
    +270
    So have you installed the Fall creators update then? Just because you get no issues elsewhere doesn't mean it might not affect RF2.
    Have you turned plug ins off? As outlined in the initial beta release details from Studio397.

    If you have installed the Fall Update make sure your Runtimes are up to date, and other drivers of course.
     
  5. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    These are plugins like Delta, Pedal overlay, etc. that should be disabled in VR (DX11?). There are plugins switches in Settings.
     
  6. Cote Dazur

    Cote Dazur

    Messages:
    673
    Ratings:
    +349
    I am not using any of those.
     
  7. Szymon Olizarowicz

    Szymon Olizarowicz
    Premium

    Messages:
    652
    Ratings:
    +241
    I'm having problems in VR as well. Yesterday I was able to launch in VR, only to find out that I'm set in the 'theatre' mod and rf2 is playing on a flat screen in front of me.
     
  8. Ze70R

    Ze70R

    Messages:
    47
    Ratings:
    +7
    Szymon Olizarowicz , same story here ..... I`m set in Theatre mod rf2 is on a flat screen.
     
  9. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    What version are you using? 1108beta, 1109, or 1109 beta?
     
  10. Ze70R

    Ze70R

    Messages:
    47
    Ratings:
    +7
    I'm using 1109 beta
     
  11. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    I asked because @MarcG posted in the S397 forums about a possible solution... I think he reinstalled and first chose 1108b, then back to 1109 (or 1109b, I don't remember).