1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

VR mode enabled causing FFB issue

Discussion in 'rFactor 2' started by Angeltheartist, May 6, 2017.

  1. Angeltheartist

    Angeltheartist
    Premium

    Messages:
    175
    Ratings:
    +27
    I am having a FFB issue when in VR mode . I use a OSW Direct drive wheel small mige . When I run the game on my triple screen setup the FFB works properly no issues at all. Once I enable VR mode and restart game all FFB feeling is gone I can drive the car just no FFB sensations coming thru wheel. Once I disable VR mode and restart game and using my triples all FFB working properly.
     
  2. Gijs van Elderen

    Gijs van Elderen
    Premium

    Messages:
    4,571
    Ratings:
    +2,358
    https://www.studio-397.com/2017/05/open-beta-with-directx-11-and-virtual-reality-support/

    Known Issues

    Plugins that render to the screen will not work any more. These plugins all depend on DX9, so their authors will need to update them. That said, we at S397 are working on improving the way such plugins render to the screen to make them integrate better with our new HUD, VR and each other. In general, for most plugins, there are known alternatives. Feel free to discuss these on our forum or on Discord. We’re glad to help!

    Content using LDR diffuse maps instead of correct albedo presets will work, but may have strange effects at some times of day and night, such as glowing surfaces. See: http://wiki.rfactor.net/index.php?title=AlbedoMap

    There is a known issue with losing FFB in VR. As a temporary workaround, first open SteamVR manually before starting single player.

    As stated above, we are still optimizing performance of DX11. As confident as we are that most of you will experience a nice boost when comparing the same settings in DX9 and DX11, we are aware that some of the new post effects, especially at higher settings, require a lot of memory on your graphics card. Future builds will bring improvements.

    Some users may experience black track surfaces/boxes around the car. Deleting files from Shaders and CBash folders (located in \Steam\steamapps\common\rFactor 2\UserData\Log) and reloading into the sim and track should fix this.

    If the new content is not available, look above at the paragraph about content updates and make sure you are subscribed to the new items. Also check if you still have existing content that might still refer to old versions (like race events you made, or downloaded when joining a server). Check the version numbers when in doubt!