1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Very strange problem

Discussion in 'Stock Car Extreme' started by s2173, Feb 11, 2016.

  1. I started GSCE today and it suddenly was running at 15 fps. At tuesday it was working just fine. In the meanwhile I had not done any system or hardware changes.

    Removed the whole game folder and downloaded it again from Steam. Unplugged all controllers. Deleted any nvidia profiles. Uninstalled any unnecessary programs. It was running the same way, without any mods and brand new driver profile: 16 fps. Reduced every detail to minimum: 18 fps. Tried running windowed, disabling steam overlay, disabling mirrors and gui elements, changing d3d9.ini with a sweetfx one, reinstalling directx 9 from the support directory, no result. MSI afterburner showed gpu usage of 10 percent, cpu usage of 18 percent...

    Went back to the other install and noticed that it was running in low fps only when I was in car... replays and menus tho were running as smooth as before, even quick replays, no matter if form cockpit or outside cameras. When I tried to drive tho, even from swingman view: 18 fps again.

    Every other game works as good as before. I got no idea what the problem is and what I'm supposed to do... reinstalling windows is not something I want to do right now. I could't find out how to disable the track map, I guess this could help...

    System: GTX 550ti 1gb, Windows 10, pentium core2quad q8200 cpu, 4 cores, 2,33 ghz, 4 gb ddr2 ram at 800mhz.
     
  2. DaVeX↯

    DaVeX↯
    Premium Member

    I had the same problem with beta, no problem at all with the regular install.
     
  3. I don't have beta, it is regular steam install... and as far I know, my game has not been updated in atleast a month.
     
  4. Paul Bennett

    Paul Bennett
    Premium Member

    I used to 50-60 fps on WinXP dual cpu an 1gb card, at medium settings no shadows.
    That was only last year

    Edit : did you verify files on Steam ?
     
  5. I moved the old install, pressed "delete game content" in steam, then downloaded the whole game all over again. It didnt help, so I doubt verifying the files will do anything more.

    Performance was very good, around 180 fps when alone on the track... and is still very good in replays, just not when driving...
     
  6. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium Member

    Heard some examples where it was the game controller that caused it. Basically the communication between the software and the wheel. Maybe try reinstalling the wheel and drivers, using different USB port (preferably directly on the motherboard), etc.
     
  7. I unplugged all wheels and controllers and tried to drive with keyboard, fps was still the same.
     
  8. DaVeX↯

    DaVeX↯
    Premium Member

    Have you used some vr app or track ir software?
     
  9. I installed freetrack ir at one point, and then uninstalled it. Can it still affect anything somehow?
     
  10. DaVeX↯

    DaVeX↯
    Premium Member

    Not sure but I had the same problem after a freetrack based app testing...
     
    Last edited: Feb 11, 2016
  11. I tried removing TrackIrPlugin from the Plugin folders, but nothing changed. Then I noticed a TrackMapPlugin.dll in there...removed that one, and now its fixed. 176 fps at pretty much max settings...

    Well, that settles it then... I dont really need the map, and its often buggy or flickering... its just weird that it suddenly has such severe effect on performance. I was running default tracks, not modded, so its not that neither...
     
  12. mycarlooksfast

    mycarlooksfast
    Premium Member

    Weird, I had the same problem yesterday when I fired up SCE after an rF2 session. Thought it was a hardware issue, so restarted system and updated to newest Nvidia drivers, problem persists. Game was working fine last time I played it, not sure what happened between then and now. Other sims and games work flawlessly. Deleting the track map is not a good option.

    Running single GTX780 on triple screen 5900x1080 resolution, was running 150+ fps before this problem, now choppy slideshow.
     
  13. having the same issue, running windows 10 and gtx 970, went from avg 190fps to 18fps
     
  14. Are you running windows 10 too? Maybe some sneaky windows update... I haven't updated my graphic drivers yet.

    Why is deleting track map not an option? I actually think there are supposedly multiple different versions between 1.3x, 1,4x and 1,5x... maybe we can just replace it with older version file?
     
  15. mycarlooksfast

    mycarlooksfast
    Premium Member

    No, haven't made the switch to W10, still on W7. None of my software or hardware changed since between when it was running fine and now.

    I like the track map a lot, so deleting it isn't my favorite option at this time.

    I hope someone knows whats going on here and can help fix our problem.
     
  16. DaVeX↯

    DaVeX↯
    Premium Member

    @s2173 hey mate wich trackmap plugin you deleted?
     
    Last edited: Feb 12, 2016
  17. Tobias Röhner

    Tobias Röhner
    Germany's greatest Indycar Fan. Staff Premium Member

    Had the same problem just now - deleted that trackmapplugin.dll and that fixed it.
     
  18. yes i was getting 35fps on a 980ti .... WTF untill i changed this

    Delay Video Swap="1" // Whether to delay video swap if card is busy - this should only be used if framerate clearly improves - otherwise it is only delaying response time

    i limited to 120fps in nvidia inspector and have my super-sampling up everything ultra 1080p 25 cars, locked at 127fps.
     
  19. xnorb

    xnorb
    Premium Member

    For some reason my FPS dropped too. But my W10 often freaks out when the XBox gamepad is connected ;)
     
  20. i recently added american truck simulator, could it be causing the conflict