1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

v1.50 / v1.51 CTDs, crashdumps and general game start-up troubleshooting

Discussion in 'Stock Car Extreme' started by Renato Simioni, Oct 31, 2015.

  1. Renato Simioni

    Renato Simioni
    Reiza Studios

    Make sure to to check the checklist of common issues below as there are some things you as user should also do to avoid trouble when running Stock Car Extreme:

    • Verify if there are no security programs such as a firewall or antivirus interfering with the game initialization. You may need to temporarily disable or configure them to exempt the game executables;

    • Verify If you are running the game as a Windows administrator - if the user is not an administrator, right-click the game icon and select "Run as Admin";

    • If running from Steam, sure the Steam app is not running in Windows compatibility mode (right-click the Steam icon, and check settings in Properties);

    • Make sure your video drivers are up to date;

    • Try installing the game in a folder other than the Windows default “Program Files” folder;

    • Make sure you run GSC Config to set your graphic options correctly;

    • After creating a fresh profile, make sure to double-check your driving aids & controller speed sensitivity to make sure they match what you had before;

    • If you get a crash on startup, make sure you have installed the DX9.0C that comes with the game (by running \Support\DirectX\Install\DXSETUP.exe);

    • If you do the above and still crashes, or if you get a black screen when escaping from a session, delete d3d9.dll from the game root folder;

    • Make sure coreshaders.mas is the only file in Gamedata\Shared folder;

    • Delete dinput8.dll, FanatecLEDs.dll from root folder & ReizaGSC.dll from Plugins folder (if you have them);

    • Since there are several new parameters for both cars and tracks, it is possible that some MODs will not work 100% and will need to be updated to use the new features (please consult this thread to learn you may update your mod);

    • If the game hangs on exit, check if LWEMon is still running in the background and terminate it (to avoid it hanging, just launch Logitech Wingman Monitor before you actually start the game;

    • If you are running outside Steam, make sure you run the Sync at least once after completing it the first time to make sure all files have been updated;

    • Finally, if you want less trouble when upgrading SCE, consider migrating your copy to Steam - you can retrieve a Steam key for your copy free of charge from here if you haven´t done it already.

    For further reference you may also consult this guide.

    The topic will be updated as we learn any other eventual issue.

    Please note that this thread is just for troubleshooting start-up issues. For in-game bug reporting and other issues, please refer to the v1.50 bug report thread. For other feedback or further instructions please refer to the v1.50 release thread.
     
    Last edited: Jan 4, 2016
  2. Rht

    Rht

    Tried all of the above but still the game will not load , when I click on the GSE.exe I briefly see a small screen then nothing ?
    Any ideas ?
     
  3. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    We forgot to add a note to run GSC Config again to make sure your graphics are configured correctly. Have you done that?
     
  4. Rht

    Rht

    Yes I tried that as well ...
     
  5. Desinstalei e reinstalei o jogo do zero, mas ao entrar no mesmo ele volta para o windows...
    Uninstalled and installed the game, but on entering the same it back to the windows ...
     
    Last edited: Oct 31, 2015
  6. Now the instructions have been amended...most might get it working now ;)
     
  7. Solved
    Can confirm that a full deletion of the Plugins folder located in the root directory and then using GSync to update again has fixed the stuck in garage problem. All is well now.
     
  8. Renato Simioni

    Renato Simioni
    Reiza Studios

    It seems a lot of people had issues with ReizaGSC.dll in Plugins folder, the mistifying thing is that file should never have been there (it was embedded in the exe in all previous releases). It´s not in any of the update packages either, so we´re at loss where that came from. Maybe it slipped in Sync at some point... If anyone figures out where they got it from we could really use the info.
     
    • Love Love x 1
  9. I play SCE on "Windows 8.1" now. And in my case, "Windows Compatibility Mode" worked.
    To be more precise, "Run this program (GSC.exe) in compatibility mode for Windows 7", then I could launch SCE.
    I'm not sure this works for everyone who has the same issue on Windows 8.1 though, just for information. :)

     
     
    Last edited: Nov 2, 2015
  10. arniesan

    arniesan
    Premium Member

    Have you got Webroot as your Firewall; if you have it is an old problem that Webroot fixes, but when some updates are downloaded, it comes back on times.
    If you have Webroot, turn Webroot off, start the game, which will run ok, then Alt/Tab out and restart Webroot, click back back into the game and it will continue to run ok.
     
  11. Rht

    Rht

    Solved my problem , just deleted the local folder and reinstalled it , all good a the moment ....
     
  12. Marco Forestieri

    Marco Forestieri
    Premium Member

    nothing work as usually after i update it...... i tried everything above ...im very frustrated
     
  13. wrong message...
     
  14. Hi !

    I've got a problem at startup: blank screen but UI sounds... I have done all recommanded manipulation (dx setup, files delete,etc.). It's a fresh install via steam.

    Any idea ?

    Thx :)
     
  15. I've installed the game (steam version) on a brand new laptop (geforce 965m), followed all the instructions and... it doesn't work. The game does actually launch and I can see the menus and everything... but after a few seconds it just closes.

    The game did work perfectly on my desktop machine for years, but I've been away from home for a month (and will still be for another six months) and wanted to just fool around with the game meanwhole (I obviously don't have my steering wheel setup with me, either)
     
  16. Renato Simioni

    Renato Simioni
    Reiza Studios

    For those still finding issues, I´ve updated the opening post with some older but still relevant troubleshooting info from previous releases - please verify.
     
  17. Gringo

    Gringo
    Premium Member

    This sounds like similar problems other people have had... the solution was to remove your video drivers with (freeware) DDU (Display Driver Uninstaller) and then reinstall your video drivers.
     
  18. Yeah ! it worked :) now i'm stuck in the garage, let's try to remove the plugins...
     
  19. d3d9.dll delete fixed my pb, i'm enjoying this version . Thx :)
     
  20. Dennis Phelan

    Dennis Phelan
    more about staying on track. Premium Member

    I can't find my old car setups. I can't see the ones in my UserData/Dennis Phelan/Settings/Track either. Can I still use my old setups? Is there something I can do to use them? Where are the latest ones stored? Most everything else is great!