1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Using SIMR-F1 with F12014

Discussion in 'Sim Racing Hardware' started by Tdudek, Nov 24, 2015.

  1. I have a wheel that utilizes SIMR-F1 that I am trying to get working with F12014. I've downloaded the SLIMAX Manager and it recognizes the wheel, passes all the tests, etc. However when I launch the game, all of the buttons and encoders work fine, but no shift lights, warnings... I suspect that the game is not sending the data properly...

    I read the install guide on EKSIMRacing and it has a section about how to edit the config.xml file in the hardware settings directory, and I've done this. The only thing I notice is that the instructions want me to set the port to 20777 and I do that, but the game resets it to 10001.

    I'm running the game through steam, so I don't know if there is a steam settings file that has to be changed?

    Could definitely use some help/guidance with this!

    Thanks!
    Tony
     
  2. Some of those Codemasters game have 2 of those hardware settings files. One in the main folder and the other in the documents folder. Just to be sure, I'd edit the other one too. I had a similar issue with another piece of software and that particular file. The one I was instructed to edit turned out to be the one that game wasn't even using.
     
  3. So I have since learned that when I launch the game from Simcommander, it overwrites the confit file to set the port to 10001, which is what sim commander is using for telemetry input. What I've tried to now do is to use the settings area within simcommander to pass the data through to port 20777, which is what slimax needs to feed data to simrF1. Unfortunately this is not working... Tomorrow I will attempt to use the Codemaster Proxy within slimax mgr.... Unless someone out there has figured this out already...
     
  4. So I left the config file with port=10001 and edited the extradata =3, then set it to read only. I get an error on startup but finally everything works great!