1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB audio support?

Discussion in 'Stock Car Extreme' started by PIO79EK, Oct 27, 2015.

  1. Recently I got a Mayflower Electronics Objective2 dac/amp unit. There is a strange problem whenever I launch SCE - about a 1 minute delay before the main menu shows up. Sound and everything still works fine except for that annoying delay.

    Also when I am in the garage and try to drive, there is also a lengthy delay. As well as when I exit back to the main menu the same problem.

    This happens in GTR2 and Formula Truck.

    Does SCE support USB audio or is it something wrong with my setup?
  2. tpw


    I use a Topping TP30 DAC/Amp with zero issues, and occasionally a Logitech USB headset, also without problems. I'd say there is something untoward happening with your setup, but I'm sorry that I have no ideas where to start.
  3. I am using the standard windows driver for generic USB audio. Already tried different ports USB2, USB3. Perhaps reinstalling the game might work. Dirt Rally loads and runs fine no hangs no delays, same with RBR. Very strange.
  4. Same problem here with another USB DAC (HiFimeDIY U2 Sabre Async), very annoying. Other games also working fine (R3E, DirtRally...)

    Maybe Reiza could check to upgrade their version of the "miles sound system" (mss). R3E is Using a DLL marked as version 9.2 and is working. Unfortunately just replacing DLLs doesn't do the trick.

    Just guessing but maybe it's the music/video handling that makes things slow, those async DACs have internal buffers, maybe the game thinks it has to wait for those to be drained?

    Strangely another old game using mss (sid meier's pirates) works just fine as well.
    Last edited: Nov 7, 2015
  5. I have problems as well regarding this, but I can't play the game at all, just freezes on a black screen and have to kill the program. I hope we'll get a fix at some point.
  6. xnorb

    Premium Member

    Using a Steinberg UR22 as audio device and have no issues with it.
    I'm also sure that there are many guys using Logitech USB headsets without problems.

    So, if you unplug your mic amp it works without that delay?
  7. have you waited a longer time? I thought the same until I found this thread and then waited much longer and the main menu came up.

    not using the DAC for audio output fixes the issue, no need to unplug, just not make it the standard output device. Using a cheaper usb audio solution also works. It must be some weird interaction, as I haven't found another game yet where the problem arises.

    Made a minidump for the developers while I was waiting for the primary menu to show up, sent a PM to one of the Reiza guys with the content

    @xnorb it's not a mic amp, but headphone amp for audio output. Windows lists it as "SPDIF" device.
  8. Yeah, I waited and I could play properly, it's just that the delays are really annoying.

    Don't have any other audio devices to default to and I wouldn't want to get back to onboard sound because it sucks and my DAC is just too good to upgrade or change just because of GSC. I'm content on waiting for a fix.

    rFactor has this same problem so it probably has something to do with isiMotor or obsolete Miles components.
    Last edited: Nov 9, 2015
  9. Via PM was in touch with Reiza on this, and sent them log files, it seems unrelated to audio, rather the hardware input code thinking that the audio controller may be an actual game controller or so, probably involving time-outs in the communcation and such.
  10. as the issue wasn't addressed in 1.51, is there anything those who suffer from it, can do to help improve the situation? (other than not using the usb-audio ;) )
  11. You have probably already tried this, but if not: make sure that the DAC is the only device on its USB port. (Don't use a hub or a daisy chain with other devices.)
  12. it's directly connected, and as the original thread starter mentioned, changing ports didn't help.
  13. found a partial workaround, change the default audio device to your mainboard audio device when the game loads or whenever it is about to go into the main menu.

    then when in race switch default audio output device to your usb-audio.

    there is some tools that allow you to do this switching via hotkey/commandline
    for example some googling gave me this https://github.com/sirWest/AudioSwitch
    still not great, but can help reduce the 1 minute wait...