1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Unable to join servers

Discussion in 'rFactor 2' started by Galin Dimov, Jan 6, 2016.

  1. Galin Dimov

    Galin Dimov
    SimDrive

    Hi Guys,I am unable to join certain servers and also unable to join any servers sometimes (including the official ISI ones). Basically, I click on the server and nothing happens (the RACE button never flashes and is grayed out). Sometimes, switching spectator mode from on to off and vice versa (doesn't seem to matter which way I change it, just for as long as I change it) helps and the server becomes available. Even with this "workaround" however, I still cannot join some servers. Yesterday, there was the club event and I basically couldn't join no matter what we tried (@Matheus Machado was helping out as well and mod/series were installed but nope, I was never able to join.
    Not only that, but even if I am able to join a server, if I click on 3-4 servers from the list without actually joining any, even the ones that were available few seconds ago become grayed out!
    I have verified the integrity of the game on Steam like 3 times now and it's becoming really frustrating. Considering the online part of the game costs extra, I am expecting it to actually work.

    I posted this on the official support forums and 0 responses. Does anyone know what the problem is?
     
  2. Is you Build up to date or are you running an older build than the server?
     
  3. Galin Dimov

    Galin Dimov
    SimDrive

    I am running the latest build (1036) and the game is being auto updated via steam. The server and game builds match.
     
  4. That sounds like an unreliable internet connection. Are you using WiFi? If hardwired, have you replaced your network cable? Rebooted the routers/switches?

    As I recall, another possibility is a corrupt player.json.
     
  5. Galin Dimov

    Galin Dimov
    SimDrive

    I am using cable yes...but how can the cable be the cause for the symptoms I am describing? Router/PC rebooted yes.
    Shouldn't verifying the game integrity fix the JSON file if there is an issue with it? I am lost on this one...
     
  6. Tobias Röhner

    Tobias Röhner
    Germany's greatest Indycar Fan. Staff Premium Member

    Does the steam version of the game come with the same launcher that is used in the non-steam version? There's another option to verify your game files there.
    Otherwise, you can try to contact support@rfactor.net.
    Supposedly, they do actually answer, though I haven't had any direct contact with them.
     
  7. No, verifying the game integrity won't fix an issue with these files so you need to perform the following:
    Remove the player.json and config.ini (cut/past to desktop to keep a back-up)
    - launching rF2 it will create a new clean config.ini and player.json.
     
  8. The Ethernet cable going from your pc to the router can have a broken clip so it's not making firm contact in the socket, it might have gotten run over by a chair, or kinked in a door. About 6 months ago, I was having similar symptoms, though mild, and replaced my Ethernet cable which cured the problems (then I moved and only have satellite Internet... but that's another story).

    Verifying game integrity is only going to verify that the template for the player.json is not corrupt.
     
  9. Galin Dimov

    Galin Dimov
    SimDrive

    Thanks will try this

    I have no problem with any other game though...isn't that strange? Also, when I join a server, there is no problem and I can drive absolutely normally. If the cable is the problem, shouldn't I be experiencing bad online experience as well?
     
  10. rF2's connect code may be more sensitive than other online things.
     
  11. Galin Dimov

    Galin Dimov
    SimDrive

    Fair enough, this might be it. I am still wondering why only 1 of the 3 RD servers online is not letting me in. If the code that much sensitive, I'd expect to affect all servers. I don't know at this point, pretty puzzled if I am honest.

    Last night, i was able the join the RD server without any issue whatsoever.