1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

trouble getting RSRBR to do its thing

Discussion in 'Richard Burns Rally' started by James Malcolm, Aug 28, 2009.

  1. I've installed RSrbr09 with 04,06 and 08 updates, inscripted to RSRBR, but when i set the car type track type ect, no matter what i do the game seems to have standard textures and uses the standard cars, sounds etc..... :at-wits-end:

    Is there something i'm missing?? does it work on Vista?

    Been a long time since i've played RBR, and used to be right into the MODs but its been so long i'm virtually a reborn MOD noobie!!

    Also what is the maximum resolution you can get it to run on, and how do you do it?

    thanks for any help you can provide guys
  2. Do you start a session through RS Center?
  3. Yeah have RS center running choose the car, the track, the mod etc, but whenever it starts (Launch RSRBR09) still just the standard gear, it does make three quick pinging noises as it loads up which could mean a wee problem occuring, but i've done it half a dozen times without success.
  4. Strange, it never makes a pingy noise here.

    The procedure is in the main RBR thread under the mod title, in the stickies. Are you sure you downloaded everything, installed it in the wright order?...

  5. Warren Dawes

    Warren Dawes
    Premium Member

    Probably not helpful, but did you start with a "clean" installation of RBR before adding the RSRBR mods?

    I have a 24in monitor and run RBR in 1920 x 1200 resolution.
  6. Warren Dawes

    Warren Dawes
    Premium Member

    One obvious question, just to check.
    Are you selecting "mulligatawny" as your player profile when you start RSRBR09? If you select your own personal profile, you will only get default cars.

    Another thing to check, make sure that your number, username, and password are correct in the upper left hand section of RSCentre, you may even need to re-enter it. Take care too, it is case sensitive (I forgot to use capitals and had similar problems).
  7. I am having similar problems to the original poster. I get the 3 "bings" noise approx 2/3rds of the way through the loading bar in rsrbr, also the game never remembers my controller setup for my wheel, and it never brings up the car that I have selected in the drop down options either.

    This is quite enfuriating, as I would like to come and join in on a rally stage or 2 with you guys.
  8. All changes to controller options must be made in RBR by launching the SSE or DLL option from the RSCenter 'Play Alone' tab , launching the profile mulligatwany and then changing setups...

    Mine 'bings' as well but loads up fine. You are choosing the pack and mod from RSCenter, aren't you?
  9. yes I am choosing the pack etc there. This i might go for a complete reinstall of it all. I had the game installed beforehand, and i'm not sure if it was previously patched or not (probably was) so hopefully that might cure it.

    As for the controller setups, I have done them in both SSE and DLL, but they are still not saving
  10. ok, done a complete reinstall now, without loading any patches to the original game, and then loading all the RSRBR stuff as instructed. I am still getting the same problems with the game. It doesnt save my controller config (even after adding it to the mulligatawny profile and saving it in both RBR SSE and RBRdll) it also doesnt seem to load up the correct car - selected Lancer evo 9 from the abw-08 pack, but still loads up a Scooby.

    The only weird thisg I came across while installing was that a couple of registry settings wouldnt change when I installed the main RBR mod. I opted to "Ignore" these and proceed as normal. Could this be the problem? AVG also recognises a couple of files as trojans, but again, I ignored this to allow them to continue.

  11. that's definitely not going to help... it probably wants to override some of the original settings with stuff that points to the mod....

    i take it you ran it as admin etc?
  12. I believe so. Maybe I should do another reinstall with avg turned off and recheck the "admin" permissions (can you remind me where to do that in Vista 64? - just had a complete mind blank on it!)
  13. i have avg and it never said a word... weird...

    anyhoo... i have no idea about vista man... i just know it's choosy about permissions.... (still living in xp ftw etc)
  14. Here you go... CLICK ME

    I reckon UAC might be the prob. Really can't think of what else it could be. You are applying the mod to an unpatched version of RBR?

    AVG yelled at me too, but I just ignored it and installed the 'Trojans', hoping for even more horespower... (geddit, see what I did there?)
  15. yes, definately applying to an unpatched rbr.

    cheers for the assist with the UAC stuff, will retry tomorrow and see what happens
  16. right, trying again now. UAC and AVG both disabled, all uninstalled and about to reinstall now - wish me luck, cos if this doesnt solve it then I am at a complete loss!
  17. me a happy bunny! it all seems to be working ok now, even though I did still get 2 errors at the end of installing the main RSRBR mod, pictured here:


    but after that, all seems to work ok! Result. Now I just got to learn to stay out of the trees!
  18. this is ze echsolent news mate!

    i wouldn't worry about either of those errors there... they're old school win32 components that probably don't even get used by vista - or, more specifically, it already has its own equivalents....

    looking forward to ya coming to eat dust with us soon... :D
  19. I also got those 2 errors Mike and everything is running fine here.
  20. yeh, its working ok for me too, just got to work out how to join in on the online rallies now