1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tree Textures flickering in GTL & Gtr2

Discussion in 'Bob's Track Builder' started by Brad Dibble, Mar 18, 2012.

  1. I get some tree tree textures flickering on and off in the game. Does anyone have any idea what might cause this? And does anyone have any suggestions on how to fix it? Thanks
  2. What kind of flickering? Rapid on/off or are they appearing when you move close to them? The first, i don't know what's causing them, i got them too and it's pretty much random if they bug or not. If it's the latter, increase LOD
  3. Its not related to LOD, but some thing to do with the texture, or how the object gets rendered.
    Same Textures/objects in rFactor are rock solid.???
  4. I have those too. It seems to come and go, in one eport they flicker and without doing any tree-related changes they work. One thing i've had lately i s that GTR2 crashes to desktop like i have a faulty sized texture. I do a new export without changing anything and it works.. But back on-topic, i would like to know what causes that flicker too...
  5. I notice that usually one face blinks on and off but not all faces. Rotating the object (trees mostly) helps but does not eliminate the problem.Also saving the file as DTX3 seems to help but not eliminate the problem.
  6. I had the same problem with tree textures flickering and when I renewed my graphics card the problem was resolved....maybe it was a coincidence but thats what happened..
  7. I also replaced my graphics card and no joy.
  8. I sort of fixed the problem by using double textures on each face of the objects, one with alpha transparency and the other with chroma. this is not the optimal solution but it worked in my case.
  9. ebrich

    Premium Member

    Have you tried it just with chroma? I use, just that, every time without problem.
  10. yes, tried various alpha and chroma transparency settings, so far only both on each face seems to work.
    Im reasonably conviced that this has something to do with the graphics card driver, but i have updaded and back dated the driver without success so far.
  11. ebrich

    Premium Member

    Whats the graphics card? Lots of information - just might ring a bell with someone out there.
  12. Same here, alpha is nicer but too expensive and you can have only some number of transparent textures at any time on one point on screen. The order gets screwed if there are too many so some of the foreground vegetation start to turn off... Chroma is different, it's 1bit so there can /basically) unlimited chroma textures at the same time...
  13. My Graphics card is an nVidia 1 GB 9800 GT. This seems to be a somewhat common problem with the nVidia drivers, based on the little I've been able to piece together so far. I have distributed my current projet to about 10 people to test out, only one other person has mentioned having this texture flickering problem, he also has a older nVidia card ~ 9800 something with less memory. Its intresting to note that I had never seen this before until I had a major computer crash that screwed up several device drivers. I had to update my network card, the video and audio card divers. Once I got everything working agian I noticed the texture flickering. replacing the graphics card and updating the driver did not correct the problem. Changing the antialiasing settings in the device driver or game setup has not worked either. I have posted the problem in the nVidia fourm but have not gotten any responce. So far the double texture approach is the only thing that has worked so far. I'm still trying to find out what the actual sorce of the problem is.
  14. GTO7900 and flickering problems can be reported on some occasions, some carefully object manipulation adn/or location change has solved them all.