1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thrustmaster TX458 - PC Issue

Discussion in 'Sim Racing Hardware' started by JamesU, Jul 14, 2015.

  1. JamesU

    JamesU
    Premium Member

    Hey guys,

    Hope this is the correct place to ask...

    I'm having a problem with my Thrustmaster TX 458 wheel.

    Basically, whenever i plug it into the mains and then into my PC (or the other way around, it doesn't seem to make a difference) it doesn't work properly with any game until i restart my computer with everything plugged in.

    If i open the software then highlight the wheel and click properties, this is the screen that opens:

    [​IMG]

    Whereas, if i restart my PC, this is the screen i get, and the actual screen i want/need:

    [​IMG]


    Does anyone have any idea how i can make it so it just works without having to restart?

    It gets fairly annoying when mid race, my cat runs past my PC and pulls the USB cable apart, meaning i have to abort everything i'm doing :(

    Thanks.
     
  2. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    1st Make sure your not running through a USB hub for maximum chance of no problems
    2nd Make sure you are not plugged into a USB extension cable for maximum success
    3rd Make sure your plugged into a USB2 connection for maximum chance of success
    4th Get A Dog

    HTH :)
     
    • Like Like x 1
    • Haha Haha x 1
  3. Check the breakaway cable too.
     
  4. JamesU

    JamesU
    Premium Member

    The cable is fine.

    I think it is plugged into USB2

    Plugged directly into the back of my PC

    I have 2 cats.
     
  5. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    You clearly need to 2 dogs to rebalance your problems :D

    Have you tried an alternative USB slot ?
     
    • Haha Haha x 1
  6. JamesU

    JamesU
    Premium Member

    I would love a dog, but we live in a flat so it isn't an option :( Maybe when we get a house in the near future.

    Yep, i've tried the USB slots on the back, and even a couple on the front

    It's like it knows its a FFB Wheel, but doesn't know which version.
     
    • Like Like x 1
  7. Do you have your USB ports set to suspend or always on? Have you tried re-installing the Thrustmaster drivers? Is the firmware current?
     
    • Like Like x 1
  8. JamesU

    JamesU
    Premium Member

    Firmware is most upto date.

    USB Ports are always on, i think...

    I haven't tried re-installing. I'll try that.
     
  9. Lazarou

    Lazarou
    Premium Member

    I just got a T300RS and I had the same issue, I had to uninstall then reinstall the software and drivers and now it is working fine. Not sure why it did not work first time but that is PC's for you.
     
  10. TeSL9

    TeSL9
    Pessimistic (rarely flying) Finn :) Premium Member

    Try this if reinstall is not working.