1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thrustmaster T500RS problems

Discussion in 'F1 2015 - The Game' started by Von Butters, Jul 16, 2015.

  1. Von Butters

    Von Butters
    Premium Member

    Hi folks, Im still unable to play F1 2015 because of the bug that slams the brakes on and turns hard left as soon as you start to play.
    Has anyone found out how to get around this problem, or know of any news from Codies in relation to a patch coming to fix this issue?

    Cheers
     
  2. Lazarou

    Lazarou
    Premium Member

    Try inverting your throttle and or brake map in the control settings in game. I had the same issue with my CSR elite pedals.
     
  3. Assume you have a TH8A/RS? Try and unplug that and restart the game!

    Took me a while figure that one out! Seems the game doesn't like having multiple controllers plugged in.
     
    • Winner Winner x 1
  4. Von Butters

    Von Butters
    Premium Member

    nothing sept wheel, kb/m, im still having no fun with it.
    back to head scratching!
     
  5. Are you using the T500 control setting in the game? Try using the custom one and set your inputs manually. That was a temporary fix for me until i found removing my TH8 shifter fixed it properly and i could go back to using the T500 preset.
     
  6. Control Panel, devises, remove HID-compliant game controller
     
  7. This T500rs glitch specific to PC's or does it extend to the PS4 :cautious: ?