1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Throttle Response

Discussion in 'Stock Car Extreme' started by Lazarou, Mar 28, 2014.

  1. I have had this small problem since i bought GSC 2013/Extreme, and the new V12 fantastic update has just highlighted it again. My pedals are Fanatec CSR Elites but some reason in GSC the game doesnt seem to respond to the first 10-20% input of throttle and these V12 beasts need all the delicate response i can get. Has anyone any idea why this would be as they are fine in all my other games and checking the properties in windows shows they are fully responsive. My settings are below.



  2. Maybe it's the RX Axis deadzone, you seem to have set it to 10%.

    Seems to be 10% for the brakes too (RY Axis).
    • Agree Agree x 1
  3. Nox

    Staff Premium Member

    Yep, looks like deadzone.
  4. Sun Levi

    Sun Levi
    Premium Member

    If there's still dead zone, re configure the throttle. That fixed it for me.
  5. Probably should have checked the deadzone first, chump! There still is a hesitation even with 0% deadzone and 100% sensitivity. How do i re configure the throttle?
  6. Try choosing another preset from controls menu. I had a problem when i first set up the game and it had a ca. 50% default deadzone on my throttle pedal. Then i switched to 'paddle' preset, edited axis and buttons to my liking and now i have the whole 100% range on my throttle pedal.
    • Winner Winner x 1
  7. Gold star for Jan, just picked another profile changed the settings i wanted and now sorted. Only been bugging me since GSC came out. Should have just asked here first .

    Thanks for all the help. If you give me all your bank details, cash card number etc i will deposit a large reward. ;)
    • Like Like x 1
    • Winner Winner x 1
  8. Nox

    Staff Premium Member

    Donuts can be sent to RD Staff Headquarters... :-D
  9. Breakfast of champions.
  10. @Paul Smith

    Yep I get the same thing except with a T500RS. I've set my throttle to 100% but the deadzone is still there.

    I noticed that the T500RS profile that is included didn't have the deadzone so, with high hopes, I based my new one off that. However the deadzone came back again. :poop:

    EDIT: OK ignore me this seems to have worked now. It seems the game didn't 'remember' the new setting until after I had restarted. I tried it tonight and everything was fine.
    Last edited: Apr 8, 2014