1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Texture Problem with my custom object

Discussion in 'Bob's Track Builder' started by Pedrosilvaaa, Jan 3, 2013.

  1. Hello everyone. So I am trying to create a very simple object using Google Sketchup (just a rectangle with a texture attached to it) to make some custom textures for my track but It doesn't show the image correctly... it appears to be "blinking". As I move the camera around it looks like there are some white stripes all over it and it just looks ugly. See image:


    I'll upload My Xpack:


    Thanks and I'm hoping someone can help me =D
  2. Hello,

    Make your sign into a box by making it 10mm thick, with a picture/texture on all 6 sides.

  3. Will tried this night when I get home.
    Thanks for your help =)

    EDIT: making it into a box with 11mm thick and aplying textures/images on all 6 sides made it work correctly on BTB but once I exported to RBR it just showed a black image where the logos should be =S


    Ideas? =)
  4. could put the texture on the other side (in sketchup) or change the sun direction (in BTB)
  5. Sorry, I dont have RBR.

    Try changing the texture to see if it showsup correctly, then it will eliminate the texture as the problem.
  6. Obviously you have that face(s) doubled. Delete it in SK and I hope it should be better.

  7. If you mean that "export two-sided faces" when exporting from sketchup then it has always been unchecked =s

    Moving the sun around didn't help as well.

    I also tried to create a different texture with a different image using the same method and it still showed black in RBR. (so I guess it wasn't the original texture problem there)

    HOWEVER this texture was a dds file. I then tried using the same texture but as a jpeg. format and now it's working. Problem is I would like to avoid using jpegs in my track cause I've heard they tend to lag more than dds format and I've had many problems with jpegs before. So, is there any trick to make dds files work as they should?

    Here's how I create the dds texture:
    - Open original image on paint.net
    - Edit it and then save it once as jpeg and then save it again in dds format (using deafult export settings)
    - Open sketchup and create object (in this case a box) and apply the jpeg texture (because sketchup can't read dds files). Then export it as a 3ds file (once again default settings).
    - Open xpacker, load 3ds file and change the jpeg texture for the dds one. Save and Export to btb.
    - Open BTB and export to RBR

    Outcome -> Black image where the texture should be

    Only works if I don't change the jpeg for the dds on xpacker =s

    What I'm thinking is it could have something to do with the export settings for the dds (on paint.net or sketchup). Any tips on that one?

    TL;DR -> jpeg as texture format seems to work fine (for now...) but dds format just shows a black image on RBR (but shows fine on BTB)
  8. No, in Sketchup - select the (which you see as black in RBR) face and delete it. It looks like there are two faces overlapping each other and the outside one is fliped. Besides the bad effect, you have to many faces in your object.
    About dds - yes, they work much better (they have mipmaps too!) - I work in Photoshop only, can't' help you too much here. But if you work too much on jpgs, everytime you save a file, you loose some image quality due to compression. Psd, tga or dds use loosless compression (of course the target files for games like RBR are dds').
  9. Alright I finally managed to create everything I needed without a problem now =D. I'm not even sure what i did wrong before but after hours of testing and some trial and error I got there. Think the problem was related to the way I imported the textures do sketchup and also the way I I transformed the jpegs to dds files on xpacker... (I end up following this tutorial step by step and... profit! --> http://forum.rallyesim.fr/viewtopic.php?f=507&t=2668)

    Here's a pic to share my hapiness with you all ^^