• You don't get fast in order to take part in club races, you take part in club races to get fast!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Texture compression issue

Discussion in 'Racer Problems & Fixes' started by citronized, Feb 9, 2010.

  1. citronized

    citronized

    Messages:
    67
    Ratings:
    +0
    Hi,

    I'm working on my Citroën GS's shaders and I'm having an issue with texture compression with the cg shaders "dyn_standard_reflect", as you can see it on attachment.

    In car.shd compression is set to 0, and racer.ini settings texture quality is set to max. Could this be due to my ATI card ?
     

    Attached Files:

  2. boomer541

    boomer541

    Messages:
    1,347
    Ratings:
    +164
    Could be! refelections are also a problem with nVidia cards, my GTX 285 gives good reflections when viewing Mr. whippys BMW M3 but irefelectons on a car I made they are crap. A plain flat panel gives distorted reflections and I'm at a loss to figure out why.

    Perhaps one of the car making experts can enlighten us!
     
  3. Tiberius

    Tiberius

    Ratings:
    +0
    Hmm, that's a weird one, compression is evil but that's definitely not the artifacts that I get with compression.

    As with Boomer, reflections have been bugged on my 7800 and 9800GTX since forever now, lines/missing chunks in the cubemap etc (but not distortion, at least not on tracks using CG sky shaders). But textures themselves appear fine.

    Are you using TGA or DDS textures? I'm still using TGAs at the moment but I read something somewhere about mipmaps on DDS textures being bugged on some GFX cards?
     
  4. citronized

    citronized

    Messages:
    67
    Ratings:
    +0
    Well, trying to look again at my car.shd, I got the idea to check if other cars using the same cg shader had the same issue. As expected, the issue was the same with default lambo and other cg'ed cars (like the jag :) ). Then I've disable the cg shader in my car.shd, but the compression bug was still here!

    So, I've checked my ATI Catalyst Control Center and unchecked all options. That was the issue : disabling the Catalyst A.I. I had no compression bug anymore in Racer!

    Thank you for your ideas, guys ;)
     

    Attached Files: