• “Happy New Year” ― RaceDepartment
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Follow RaceDepartment also on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

Testing MAXIMUM_FRAME_LATENCY=1

Discussion in 'Assetto Corsa' started by Jim Liak, Sep 25, 2016.

  1. Jim Liak

    Jim Liak

    Messages:
    592
    Ratings:
    +328
    Hi, I did a test, recording via my phone's slow motion recording ( @100fps).



    I then counted the frames needed for the virtual hand, to move :

    Results
    MAXIMUM_FRAME_LATENCY=0 (38frames)
    MAXIMUM_FRAME_LATENCY=1 ( 27 frames)
    MAXIMUM_FRAME_LATENCY=2 ( 34 frames)
    vync 0ff , fps uncapped (~103fps) : ( 21 frames)

    So it seems that MAXIMUM_FRAME_LATENCY=1, it's not really bad since ~6frames are added over vsync on = 60msecs. It's not that bad.
     
    • Like Like x 3
  2. Glaurung

    Glaurung
    Premium

    Messages:
    1,908
    Ratings:
    +792
    Are you sure to have always this levels of input lag?
    You should try also with a moving scenery that put more load to GPU.
    In any case, I always go for minimum input lag, accepting some screen tearing, so I don't mind for vsync.
     
  3. PhilS13

    PhilS13
    Premium

    Messages:
    241
    Ratings:
    +146
    I don't know how you drive like this. 1/4 of a second is incredibly high lag.
     
  4. Jim Liak

    Jim Liak

    Messages:
    592
    Ratings:
    +328
    Me neither...
     
    • Haha Haha x 1