• Blurring the line between real and virtual motorsports
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T500RS freezing problem

Discussion in 'Sim Racing Hardware' started by Matthias Van Oyen, Oct 27, 2014.

  1. Hi,

    I have this issue with my T500RS wheel that has been there from the start (1year ago) and has not changed with any update. Whenever I open the T500rs wheel configuration in control panel the "program" freezes ever 10 or so seconds. After that it continues and freezes again. I have not experienced anything ingame but it is a pain changing settings this way as i have to act quickly between freezes.

    The only game that has this problem in-game is when I try to change the controller settings of my wheel in Assetto Corsa.

    Is this a familiar issue and is there a workaround or am I the only one experiencing this.

    I am on windows 8.1 on a heavy spec'd machine that otherwise has no freezing issues.

  2. Win 8.1 here too, definitely not getting this issue with my T500 or T300.
    Confusing issue. Are you on the latest drivers and firmware, are you using a USB 2.0 port?
  3. Hi thanks for the reply. I am on the latest driver and firmware. This problem has sustained through all the updates. I'm using a USB 2.0 on my motherboard (asus P9x79-E WS).
  4. About the only idea i have is something else on USB interrupting or some other wheel driver remnants floating around.... Then again I've had Logitech or Fanatec drivers installed in parallel to Thrustmaster ones and never had an issue.

    Heck, I even have my PC set to sleep and it wakes quite happily, so I'm not worried about it being some kind of USB sleep state either (although you could check power settings and tell it not to put USB devices to sleep, see if it helps)
    • Like Like x 1
  5. I don't have any old drivers on my disk.
    I did have some issues in the beginning with wake from sleep but these are over now. Maybe there is like you a power issue, I'll look into that. Thanks!