1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

T500RS F1 not working properly anymore

Discussion in 'F1 2012 - The Game' started by Tom, Sep 22, 2012.

  1. Tom

    Tom
    Staff Emeritus Staff

    Funny enough, I've just fired up the game and now my wheel isn't working at all - oh, the irony. No FFB in the center, more or less until I reach 1/3 of the rotation. Pretty odd, it did that the other day but worked fine when I pulled the plug and plugged it in again after a few seconds.

    To no until I restarted my computer twice today. Any ideas? T500RS F1. Other games (F1 2011, GSC 2012) are working fine.
     
  2. you have the latest drivers 2012 TTRS3
    longer the latest version of the firmware that is v.40

    anyway with these drivers the wheel goes fine
    someday when starting the game is driving me crazy and going from one place to another or is completely turned left.

    problem may be that the steam?
    I cleared the cloud of steam
     
  3. Tom

    Tom
    Staff Emeritus Staff

    I have to admit that I didn't update my drivers yet. Reason is simple, it worked with F1 2012 until yesterday. I ran out of time today and will update them tomorrow - yet, there was no update to F1 2012 so that *shouldn't* make a difference. ;)

    I also opted to disable the Steam Cloud right from the start because of the corrupted save games, so that I can back up everything directly. What you said about the wheel being all left is indeed true and also happened with F1 2011.
     
  4. I had the exact same problem Tom, try unistalling the drivers and reinstall them! Also it might be some USB issue so I suggest you chaning USB port and re-setup drivers and wheel. I hope it works for you!
     
  5. I have had some issues with my thrustmaster F430 wheel, like it says it's saved my pfofile set-up, but when i launch the game it feels crazily slow to respond. what I've found helps is go to the advanced wheel settings, choose the default wheel set-up, not your custom one, and then re-set all you're settings. thats worked for me everytime
     
  6. Tom

    Tom
    Staff Emeritus Staff

    I'll give it a shot tonight, just afraid the wheel will behave different after updating everything - according to the patch notes it'll change & raise the latency. :O_o:

    Thanks!
     

  7. Changes made in new driver version:
    - Solved a problem that appeared when users attempted to save force effects in the Control Panel
    - The self-calibration process has been optimized
    - Latency has been optimized and raised to 500 Hz (instead of 125 Hz) of the frame rate


    so far ive seen only positive comments about the new firmware! the wheel seems to be much smoother now and also should react faster, especially when countersteering: "Math says it has less lag now than before. It should be down from 4ms to 1ms on average." (comment from iRacing user)
     
  8. Tom

    Tom
    Staff Emeritus Staff

    Oops, I meant raise the detection rate...not latency. Thanks for pointing that out. :)

    Edit 00:16 CET: the update fixed the issues for real. Just weird that it suddenly occured. Thanks anyway! :)