1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

System Freeze with RSRBR 2011

Discussion in 'Richard Burns Rally' started by Ryan Callan, Dec 30, 2010.

  1. I have a very strange problem with RBR currently. My whole system will freeze at seemingly random times, but never longer than 2 stages after starting.

    There are no graphical anomalies upon the freeze, 2 seconds before the freeze, a static hissing sound begins and stops at the freeze. If I press CTRL+ALT+DEL, I can view my mouse moving where the Task Manager should be but I cannot see the Task Manager window. Moreover I cannot operate the Task manager via the keyboard, 'blind' as it were. If I anticipate the freeze (upon hearing the hissing), I can quickly press CTRL+ALT+DEl and get to desktop, however, when attempting to end the RBR process, my computer freezes. When my computer freezes, I can still hear the microphone feedback from TS3.

    I have installed the game freshly 3 times now, on XP 32-bit, GTS250, 4GB RAM, Athlon X2 - had no problems with 2010 at all.

    The following diagnostics have been run:

    Defragmenting hard drive
    Installing on a different hard drive
    Tweaking graphical setup
    Using or not using graphical add-ons
    Changing the 3D ratio
    Disconnecting external HDDs while playing

    None of these 'solutions' have worked. I am frankly stumped, it does not seem like a graphical problem, but more of a something very wrong in the game process. Anybody got any more ideas?
     
  2. Have you tried to run the game with TS3 off, or even running it with as many programs that are usually on turned off?
    Can the "hissing" appear at any place in the game, or only on the stage/in menu?
    Do you have the most recent Visual C++ Redistributable installed (know to cause numerous problems if not updated/corrupted)?

    This is weird stuff. I'm shooting blind here a bit, but maybe we'll hit something this way.
     
  3. Yep, TS3 on or off, crash only occurs in-game, it may appear in the menu but I'm not there long enough to full test that I guess.

    Will try C++ although I'm 99% sure I have the latest.
     
  4. Also, you may want to try to reinstall sound card drivers, graphics drivers, directx. I sometimes wonder if uninstall of RBR removes some driver components that it shouldn't.
     
  5. C++ didnae work.

    Totally stumped unless Update 01 fixes it.

    DirectX is a-OK, graphics drivers unchanged, use only on-board sound.
     
  6. Another small but very curious detail - managed to catch the crash, pressed 'ESC' and retired, that way there was no crash of the system.
     
  7. The original game works fine on its own, I presume?

    If you don't figure it out, try their forum, they should know best.
     
  8. Thanks Ashok (as the problem is accompanied by a hissing sound it's worth a shot)
     
  9. Updated graphic drivers, reinstalled sound drivers, tried the 2010 sounds, all nada :(
     
  10. Does RBR work on its own without RSRBR?
     
  11. Tell us if it helped.
    Also I presume it happens in every car you've tried? And as Senad pointed out - if you launch the game normally does it still happen?

    @Aaron - it's not perfectly untouched after installing the RSRBR, but yes, you can launch it on it's own (most of the original files are backed up to allow that during the installation).
     
  12. I have another kind of problem with 2011 version or not? If a Public Sesion has begun, I can't enter in it, like in the old version and run from the stage that is running, is the same for all of you?
    And no mather how many time I've downloaded and installed N4-2 car pack, I can't drive Subaru N10, N11 and N12 :) ! Hope with the first up-date it will fix those early problems :).
     
  13. I haven't tried RBR on it's own, however I see little point in this as, even if it does work alone, I still can't play RSRBR, which is the whole crux of the matter. There is no question of any corrupt original RBR stuff, I have an ISO install (made in case my RBR disk got damaged and it duly did, along with my GTL disk way back).
     
  14. Asking you to try it is to determine if it's a RSRBR issue or a general RBR one. Simple diagnostics by elimination :)
     
  15. There are two types of public sessions. The normal public session can be entered at anytime, but the public championship session must be entered on time to start SS1, you cannot enter this session type after the rally has started.
     
  16. Warren Dawes

    Warren Dawes
    Premium Member

    Ryan, you need to see if the default RBR works, so we can see if it RSRBR2011 that causes the problem. If the base RBR is the problem, any updates to RSRBR won't help.

    One obvious one I can think of: Do you have EAX enabled in your Richard Burns rally.ini? If so, turn it off.

    Maybe even post your Richard Burns rally.ini file contents here.

    EDIT: One more thought, did you install any of the Pacenotes mods?
     
  17. Thanks for the help guys, it's really appreciated. Will try that DEP fix, I am on a fresh install of XP also now (needed doing for a while anyway), so fingers crossed I have it up and running in a couple of hours.
     
  18. Problem is solved with a fresh OS install. I guess the OS install being well over two years old had some influence here.