1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Sweet Lamb loading error

Discussion in 'Richard Burns Rally' started by John Cunningham, Jun 5, 2011.

  1. Morning gents,

    I tested and agree with Kevin's findings:

    " :DI can confirm that if you take the FixUp.dll file out of the Plugins folder you can run higher resolutions in game.I removed folder went back to my original settings and Sweet Lamb stage ran.Put the folder back in while still keeping the higher settings and once again Sweet lamb would not run.

    Back To 800x600 with the folder in place and Sweet Lamb runs again.

    I can also confirm changing the settings for "fixaspectratio and fullscreenwindow" does not make a difference ,you still have to run at 800x600 resolution."



    So, unfortunately Sweet Lamb only runs on 800x600, which is waaaaaaaaay to low a res to playing at. If no solution is found could we perhaps just replace this stage?

    Best regards,

    jc






    Originally Posted by Jeremy Loveland [​IMG]
    Have you tried setting the res in the config file instead of in FixUp.dll ?
    I'm assuming that the resolution is changed in the Richard Burns Rally.ini file, I don't know that there is any way to change it in FixUp.


    [​IMG] Originally Posted by Jeremy Loveland [​IMG]
    Also would it be a good idea to set up another thread for this issue so it doesnt clog the upcoming event thread?



    Yep, that was my plan once I saw that it was a problem to more than just Kevin. Waiting on a reply from John to see if it fixes his issue.
    The main reason for discussing it here initially was because drivers in this event may need to know, and they need to urgently check if they are ok.
     
  2. Warren Dawes

    Warren Dawes
    Premium Member

    John, I assume you can run your preferred resolution by removing the FixUp.dll?
    If it proves to be true, those with the problem (only 2 so far) can (hopefully) simply remove the FixUp.dll for this event and run higher resolutions.

    I'm reluctant to replace this Stage at this point based on this scant info, especially since the Stage is included in the final Round of the RDRC in two weeks time.

    We need more feedback on this issue.
     
  3. I found an issue when loading Sweetlamb with some cars, but if you select a different one, start the stage then go back to the other car it loaded fine. It might be a different problem you guys are finding bt it worked for me. BTW, I'm running much higher res then 800x600. Has anyone tried it online yet to see if the problem still happens?
     
  4. I run at 2560 x 1440 and haven't had any issues either offline or online running Sweet Lamb with any of the cars available for this event.

    My resolution is set in my RBR.ini file and I don't use Fixup.dll to set my res or widewcreen I use the settings from within the RBR.ini and in RS Centre for 16:9

    RBR.ini is as follows

    [Settings]
    Depth = 32
    ForceFeedback = true
    Fullscreen = true
    MinDepthBits = 24
    MinStencilBits = 8
    ParticleQuality = high
    RenderQuality = high
    RunIntro = false
    RunStartup = false
    Sound = true
    UseCubicEnvironmentMaps = true
    UseEAX = false
    UseSoftwareAudio = false
    UseTripleScreenBuffers = true
    WaitRetrace = true
    XRes = 2560
    YRes = 1440

    Cheers Al
     
  5. Tried moving the fixup dll? Will not load

    Tried different cars? Yes, several, will not load

    With the FixUp.dll back in the Plugins folder, try a different setting in your FixUp.ini file eg. switch the "fixAspectRatio" on or off. Does that fix it? Also, maybe try the "fullscreenWindow" switch setting.Both options tried, will not load

    I guess you get the choice now, higher resolutions without the benefit of other FixUp tools, or keep FixUp but run lower resolutions. No, in that any higher res without fix up, still does not load (but does run at 600x800)
    Have you tried setting the res in the config file instead of in FixUp.dll ? Yes, only ran at 600x800.

    Tried Al's (thanks!) res: I got an error message saying 'rbr could not find a compatible 3d device and wil shut down'.... Will not load

    Only time it ran was at 600x800.

    I use an ATI HD4870 x2 (only one card), and usually run with the res maxed out and have had no problems with any other stages so far
    .

    Thanks for the help to-date

    jc
     
  6. Warren Dawes

    Warren Dawes
    Premium Member

    This is all very hard to understand and variable so far, but we need a good test (and more info) before the RDRC Round.

    What I will do for now, is to move the Sweet Lamb Stage to the end of the Club Rally (Monday Tuesday), and if a significant number of drivers can't load it, then we can decide whether to drop that Stage in the results.
     
  7. Hi John,

    FixUp does not have any settings for the screen resolution. It fixes the aspect, windowed and v-sync settings based on the configuration.
    Only if you set Fullscreen=false in the RichardBurnsRally.ini you may set XRes and YRes to arbitrary values and then the fullscreenWindow=1 in FixUp.ini applies.

    Maybe the loading problem is related to the v-sync settings.

    Try this: Fullscreen=false, set XRes and YRes to your preferred resolution, set all values in FixUp.ini to 1.
    Open the settings of your video card. Search for the v-sync settings. Do not set it to "off", let the game decide.

    BTW: The 'rbr could not find a compatible 3d device and wil shut down' message only appears in fullscreen mode, as far as I know.
     
  8. Tomas Reinicke

    Tomas Reinicke
    Premium Member

    I have no problems with Sweet Lamb offline, tested with the Suzuki and Polo.

    FixUp.ini:
    [Settings]
    fullscreenWindow=1
    fixAspectRatio=1


    RichardBurnsRally.ini:
    [Settings]

    Depth = 32
    ForceFeedback = true
    Fullscreen = false
    MinDepthBits = 24
    MinStencilBits = 8
    ParticleQuality =low
    RenderQuality =low
    RunIntro = false
    RunStartup = false
    Sound = true
    UseCubicEnvironmentMaps = true
    UseEAX = True
    UseSoftwareAudio = True
    UseTripleScreenBuffers = false
    WaitRetrace = true
    XRes = 1680
    YRes = 1050
    ShowFPS = True

    Note that I'm using Fix v 1.5

    Ati 5770
     
  9. Fixed!! (I am now very late for work, apologies for any typo's)

    Ok, so the problem (was of course my fault) was that I was not using the 1.5 fix-up plugin...

    Fixup.ini

    [Settings]
    fullscreenWindow=1
    fixAspectRatio=1
    fixVSync=1
    vSyncActive=1

    rbr.ini

    [Settings]
    Depth = 32
    ForceFeedback = true
    Fullscreen = false
    MinDepthBits = 24
    MinStencilBits = 8
    ParticleQuality = high
    RenderCarShadow = true
    RenderQuality = high
    RunIntro = false
    RunStartup = false
    Sound = true
    UseCubicEnvironmentMaps = true
    UseEAX = false
    UseSoftwareAudio = true
    UseTripleScreenBuffers = true
    WaitRetrace = true
    XRes = 1680
    YRes = 1050


    V-sync on graphics card also back on... it all appears to be working ok. Thank you, for all your help and patience. I apologise for wasting your time having not been up to date. Thomas's comment 'Note that I'm using Fix v 1.5' made me aware of my stupidity.

    got to get to work!!!

    jc
     
  10. Never had a problem myself with it. Warren, good idea for running it as last stage.
    John, with these old sims i tend to switch vsync off, always.

    As a matter of a fact, never i switch vsync on.
     
  11. Had a problem loading Sweet Lamb at first, but removing FixUp.dll seems to have done the trick for now.
     
  12. So, RBR seems to be the exception to Hubert's golden rule.

    Setting v-sync to OFF definitely causes weird problems in RBR, both in sounds and graphics.

    This is why I released the 1.5 version of the plugin after testing the new windowed mode deployed in 1.4.
    Some users and myself discovered some problems which have been addressed by the 1.5 version.


    Some words on v-sync:
    I can not see any advantage in calculating the screen buffer say 200 times (FPS) and then only actually drawing it only 59 or 60 times (screen refresh rate). This it what happens when v-sync is OFF.
    In other hardcore gaming forums it is recommended to switch v-sync on, no matter the game. Only benchmark maniacs turn v-sync off to get the max out of their iced gpu.

    So, v-sync ON and letting FixUp do it's job should be the general recommendation for RBR gamers.
     
  13. Warren Dawes

    Warren Dawes
    Premium Member

    Thanks for your help and advice WorkerBee. :thanks:

    It still puzzles me why it is only a problem with the Sweet Lamb Stage, and doesn't seem to be affecting other Stages. :confused:

    For anyone who doesn't know, to get the latest ver of FixUp, you need to download it from here:
    http://www.racedepartment.com/rbr-mods/54077-download-rbr-fixup-patch-plugin-1-5-a.html

    The version currently included in RSRBR2011 is ver 1.4, which does not have the V-Sync adjustment capability. I don't know what is planned for Update 06 of RSRBR2011, hopefully the latest FixUp might be included.
     
  14. pffffffffffffffffft sweet lamb didnt run in the race!!! (it did offline about 10 mins before)
     
  15. My experience

    Hi! RD people, i have the same situation with FRENCH MOD RSRBR, BUT! in CZ MOD i played in SHAKEDOWN MODE the SweetLamb (Downloaded from Eno72´s forum) and works fine, so, the problem is in the RSRBR MOD.

    I actually find the solution for me, and only with this track.

    [Settings]
    fullscreenWindow=1
    fixAspectRatio=1
    fixVSync=0
    vSyncActive=1

    The track is loaded fine and its OK for me now, but, i have the question, "WHY???" why this track have this problem?

    Thanks to all for sharing your questions, because the answers help so many people!

    From Argentina, "Envolved" (Medina Jose):wink:
     
  16. Actually it is not that simple.

    It also depends on the v-sync settings of the video card and on whether you use fullscreen mode or not.
    So you should post all this info to be really helpful.

    There are reports from people somtimes (!) NOT being able to drive this one in CZ MOD.

    Someone already contacted the track creator to analyze the issue.
     
  17. Warren Dawes

    Warren Dawes
    Premium Member

    Let's hope this brings the best solution, it is such a good Stage to be spoiled by this small bug.
     
  18. Hi, here i let you my config for RSRBR, thanks WorkerBee por the reply


    [Settings]
    ConstantForceMultiplier = -60
    Depth = 32
    ForceFeedback = true
    Fullscreen = true
    MinDepthBits = 24
    MinStencilBits = 8
    ParticleQuality = high
    RenderQuality = high
    RunIntro = false
    RunStartup = false
    Sound = true
    UseCubicEnvironmentMaps = true
    UseEAX = true
    UseSoftwareAudio = false
    UseTripleScreenBuffers = false
    WaitRetrace = true
    XRes = 1360
    YRes =768
    ShowFPS = false
     
  19. So, you use Fullscreen=true and do not like to switch to the desktop.

    Then fullscreenWindow does not apply at all, this only works in windowed mode.

    If you disable the v-sync handling of FixUp, the system works as before. In fullscreen mode from my experience RBR uses v-sync=on, so the frame rate is equal to the monitor's refresh rate. In true fullscreen I have never seen higher frame rates. But maybe I'm wrong.
     
  20. What i meant Workerbee, is with V-Sync on it creates a constant average of framerates so you have the feeling it's smooth. While i actually see constant stutter, mind you this is with practiced eyes from animation and movie industry education.
    Could be you all don't see this, i don't know.

    I never said anything about a golden rule, i just said, from my personal experience, i leave it off.
    Gives me smooth framerates, around 60 yeah, if you know that 40 is already a limit for our eyes, i don't care if it's more or not, as long as it doesn't go down it's ok.

    When i put V-sync on it creates stutters, alot of them...

    Probably my card Ati is the blame here.