1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuttering?

Discussion in 'Stock Car Extreme' started by mrs1986, Jan 5, 2016.

  1. Hi all!

    I'm new to GSCE, I bougth it the other day, my question is if anyone has any idea of what to do about the stutter?
    The game is smooth, but has a lot of micro stuttering while playing, even playing offline, or alone...

    My PC is powerfull enough (I think) to run the game, in fact the game never goes lower of the 60 fps, it is locked there with the V-Sync.

    Just in case, my machine is as follows:
    i5 4690k@4.0Ghz
    480 SSD
    16Gb ram
    GTX 970
    The cooling, the power, everything is up to the task, so it is not a problem about the machine, it is something I'm missing about the game.

    Thanks a lot for any help I could get!
     
  2. William Wester

    William Wester
    Premium Member

    "Search" is you friend :) There has been so much over time on this subject that I couldn't recite word for word, I would have to do a "search" to help you.

    upload_2016-1-5_12-26-58.png
     
  3. Thanks, but I'm talking about it in a decently powerfull machine and not playing online, that's why I asked anyway because the threads that were answered were in another hardware...
     
  4. xnorb

    xnorb
    Premium Member

    There's something with the replays. They seem to not run as fluid as the racing.
    (At least to me on my rig while displaying an FPS counter showing sufficient FPS)

    But while driving i don't notice any stuttering.
    i5 3550
    R9 290
    SSD
     
  5. Mmmm I didn't checked the replay, I may do it and see how does it look, but currently the issue is while driving, is like minimun, and not fps related, is like the vsync is lossing pace or something like that haha
     
  6. xnorb

    xnorb
    Premium Member

    Ah well, i don't run with VSync.
    Maybe try without it?
    Usually i tend to suggest to turn it off and if you want to save resources to use your gfx card software or something like DxTory to limit the FPS.
     
  7. Marcel Kleene

    Marcel Kleene
    Premium Member

  8. Reduce shadows to medium... It should fix it. For me, shadows on max cause stuttering even if the framerates dont budge at all.
     
  9. Try turning off time scale?
     
    • Agree Agree x 1
  10. having V-sync on in the new radeon settings thingy caused stuttering for me. turned it off and all is well.
     
  11. Thanks a lot for the help! When in home i will give these tricks a try!

    The fps are ok, like 400 or so, if v-sync is off, so all these comments come in handy :)

    Thanks a lot! I will report back after work!
     
  12. You can set the max frame rate in the game's config file without subjecting yourself to the input lag that comes from Vsync.
     
  13. alexSchmurtz

    alexSchmurtz
    Premium Member

    Yep: I also noticed a big change after setting a max frame rate in the config file, especially after v1.50. I have been able to crank everything up; before I had to lower shadows to high or medium depending on the track. Now the game runs smooth as butter with a constant 59 fps (which correspond to my screen), no stuttering and everything on max.
    Maybe have a look also at this post: make sure you have the value recommended by Alex Sawczuk. With the recent changes in the game, the value might be default in the Plr now but it helped a lot stuttering at that time.
     
  14. Turn off Special Effects, these tie in with dust and smoke and go from there.
    For me this was the main issue with stutters set my sfx to low and now stutter free.
     
  15. I tried and with no luck, the problem persists...

    @P*Funk , where do I find that file? I have to try with those files and see what i can get...
     
  16. William Wester

    William Wester
    Premium Member

  17. As said above you can change timescale in the options for the session within the game.

    For setting max frame rate go into the game folder and under UserData/[playername] you'll find a config file also named after whatever your player name is, default is just player I think: [player].PLR.

    In there you can find the line Max Framerate and then you enter an integer to correspond to your desired frame rate. In SCE for some reason you need to enter it as a negative integer, so for me I have mine set to -120 in order to get a steady 120 FPS in game.
     
  18. I didn't have time yesterday to test what @P*Funk said, but changing the time scale to none didn't make the trick...
    Just need to test that and see what happens...
     
  19. May worth a test: make SCE run on a single core
    I don't have this problem here and everything is on max. Only AA and texture quality ("performance", but used to have it on "quality" and made no difference as it did in rF2 with fps loss) is set via video card settings (HD7850) the rest is in game
     
  20. With V-sync you have stuttering? I play GSC in a laptop, with a nvidea card, and with the V-sync the game is very smoth, without it I get lots of stuttering.
     
    • Agree Agree x 2