1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strage crashing behavior in GSCX since latest update

Discussion in 'Stock Car Extreme' started by Sk3ptik0n, Sep 28, 2014.

  1. Sk3ptik0n

    Premium Member

    I have already submitted this in the bug thread, but since I have not received any response (maybe I shopuld not expect one) and this is hampering my effort to play the game., I wanted to bring it up in its own post.
    The original post is this: http://www.racedepartment.com/threads/gsce-v1-21-bug-report-thread.91815/page-5#post-1817758
    where I explain how when I launch GSC Instead of the usual GSC start screen, some sort of command line window pops up and I have to focus on the GSC window manually.

    Since I posted that, I discovered that also the game often quits when I press "ESC" to get off the track. Not always but I have not found a pattern yet.

    Also, when the game is running, beside the regular GSC window and the Command Line one, at some point a dump alert (a version of which I put in my OP) is always in the background. Initially I though that alert was there when I quit the game (intentionally or not) but I have since discovered it's always there. It's like the game crashes almost immediately but it's kind enough to let me play.

    I also tried multiple time to sync all of my installations. It syncs but the behavior remains.

    One thing I solved on the version with all my Mods (I have a clean version as well) is that I had to clean up the shared folder or some tracks would not load. I took the shared folder from my virging edition, renamed the old one and pasted it. Since then I have avoided track loading frezes, but I have to wonder: aren't those files in the shared folder necessary for some of the kods? And as I use those mods, won't they be written again since I remember a lot of them came without a ":shared" folder ?

    Thank you for any help here, it's driving me cucu.

    PS: is there a full installation file for the latest GSC Xtreme? I'd like to toss my installation and start from scratch if I can.
  2. Bez

    All the gear, no idea... Premium Member

  3. PieterN

    Premium Member

    Isn't the command line window from the real feel console ?
    Please check
    ConsoleEnabled= in your realfeelplugin.ini , it should be False
  4. Sk3ptik0n

    Premium Member

    INdeed, very good. I am not sure why I turned it on. I think because I wanted to turn on the real feel ability of reverting the feedback direction. I didn't think it would cause the console to open because in rFactor AFAIK it doesn't do that. In fact in rF1 it is usually on by default.

    Is there a way to be able to apply the realfeel keystrokes (Ctrl-4, CTRL-6 etc) for the FFB reverting and increasing decreasing FFB without the console opening?

    Or am I totally offbase?

    In any case, thank you for solving that mystery. On my virgin GSCX it stopped doing it but then I realized that's because I synced it. On my modded installation I made realfeel a read-only file so the sync would not override all my custom cars.
  5. Sk3ptik0n

    Premium Member

    Something occurred to me: if the console is from Realfeel, then probably that's not the cause of the crash. Should I upload the dump files? I tried opening them but they are gibberish so obviously I need an interpreter of sort. Most of what I found so far is designed to read blue screen crashes, not game crashes.
  6. PieterN

    Premium Member

    "Is there a way to be able to apply the realfeel keystrokes (Ctrl-4, CTRL-6 etc) for the FFB reverting and increasing decreasing FFB without the console opening? "

    These keystrokes also work without the console being open, not if your realfeelplugin.ini is read-only though. You want to turn the SpeechEnabled part on.
    Last edited: Sep 29, 2014
  7. Sk3ptik0n

    Premium Member

    Thanks, I just realized that. For some reason, when I tried that recently it did not work. Maybe I did not press the right keys or something like that (I find it hard to type and drive, which is why I usually don't bring my keyboard with me on my commute) so I figured it didn't work, I turned that on and it worked and I assumed they were connected. Coincidence.

    BTW, one of the reasons the game is crashing is the files in th "shared" folder. Seems like I have to clean it every once in a while and then the game works fine. Basically I am keeping a "shared2" folder in the installation and keep the files there. When I have time I'll try to figure out exactly which shared files is causing the crash.
    • Beer Beer x 1