• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Have a chance to win a copy of F1 2017 The Game (PC) by following RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

Steering wheel shimmy

Discussion in 'Assetto Corsa' started by Terry Rock, Dec 26, 2016.

  1. Terry Rock

    Terry Rock

    Messages:
    1,100
    Ratings:
    +377
    Has anybody come up with a solution to completely eliminate the wheel shimmy experienced by some cars in AC?
    It seems more prevalent in some cars more than others...irregardless of circuit.
    I especially notice it in the Praga R1.
    It seems to occur most when the steering wheel is perfectly straight and 'unloaded' on very high-speed, non-cambered straights.
    It's annoying as heck and takes away from the overall experience.
    The rest of the feedback feels great.
     
  2. Seria17hri11er

    Seria17hri11er

    Messages:
    62
    Ratings:
    +74
    Depends.

    What wheel are you using?

    What, settings in the Logitech/Thrustmaster program are you using?

    What settings are you using in AC?

    Are you using a LUT?
     
  3. Seria17hri11er

    Seria17hri11er

    Messages:
    62
    Ratings:
    +74
    Hmm. Well, you said "completely eliminate"... Not sure anyone can help you achieve that.
     
  4. William Levesque

    William Levesque

    Messages:
    4,894
    Ratings:
    +1,277
    Balance your wheels :D
     
    • Haha Haha x 2
  5. Terry Rock

    Terry Rock

    Messages:
    1,100
    Ratings:
    +377
    Thanks for the replies...even the funny ones.
    It's on a T500RS.
    I finally got it sorted by adjusting the settings a little bit at a time then rechecking feel.
    These settings work great and no more shimmy.
     

    Attached Files:

    Last edited: Dec 29, 2016
    • Like Like x 1
  6. Seria17hri11er

    Seria17hri11er

    Messages:
    62
    Ratings:
    +74
    Road effects at 65% is extremely high.

    The Road Effects and Slip Effects sliders are Amplifiers.

    They amplify forces that are already present and being transmitted.

    Kerb Effects is the only "canned" effect. Why? Because even if you go over a flat kerb, it will shake/rattle the wheel. Your wheel should already shake/rattle even with this at 0.

    You also aren't using any Damper in TM panel. That is part of the problem. AC needs your wheel program to allow Damper. AC uses the damper function. If you set it in TM it's not a constant damper.

    I would highly recommend you take a second shot at adjusting these settings.

    I would recommend

    TM - All at 100 except spring

    AC Gain 100

    Both Filters - 0

    Kerb 0

    Road 0

    Slip at 30 is fine.

    At that point, test one car, and one track, and only test that same combo. Pick one of the cars you had a "shimmy" problem with.

    Bring up the pedal app and check for the bar on the right to turn red while driving. If you see it turn red, your FFB is clipping and you need to lower the FFB gain for that specific car (- or + key to change FFB level for car). Better yet, download and use the FFB clipping app.

    You need to drive the car and track combo for at least 20-30 minutes to adjust to the new feel. At that point, if you are having a shimmy problem, you should use a LUT for your wheel. There is a thread for it on AC forums. If you don't want to use a LUT you can try using a little bit of Minimum Force-- 1-5%.

    Then test the change for another 10 minutes or so. If that got rid of the shimmy good.

    I'm just going to quote a post I made on AC forums for further info. Some of it I have already said above.


     
    • Like Like x 2
  7. Terry Rock

    Terry Rock

    Messages:
    1,100
    Ratings:
    +377
    I had lots of time to 'experiment' today with settings in both AC and the TM control panel.
    It turns out the only way to totally get rid of the 'centered wheel shimmy' is to add a value to Spring in TM control panel.
    I have mine set to 70 and the wheel now feel great.
     
  8. tlsmikey

    tlsmikey

    Messages:
    282
    Ratings:
    +98
    Hmm...running a T500 and here's my setup.

    Thrustmaster Panel:
    Strength = 60 (60-65 is the most linear response on this wheel. Above and below gives non linear feedback)
    Constant = 100
    Periodic = 100
    Spring = 0
    Damper = 0 (only used at low speed)
    Auto-Center = by game

    In game:
    Gain = 75
    Filter = 0
    Min Force = 8%
    Kerb = 60
    Road = 35
    Slip = 0
    No understeer effect.

    The biggest difference for me was also changing the FF_SKIPS_STEPS=0 in the asseto_corsa.ini file. That gives the full feedback rate instead of dumbing it down to around 60Hz i believe.
     
    • Like Like x 1
  9. Seria17hri11er

    Seria17hri11er

    Messages:
    62
    Ratings:
    +74
    I'd recommend you try a LUT with Min Force at 0.

    FF Skip Steps:

    Default of 1 is 150hz. 150 updates per second.

    0 is same rate as physics engine; 333hz. Some wheels don't work with that and will vibrate.