1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Steering like a boat" fixed for G27?

Discussion in 'RaceRoom Racing Experience' started by Glygoo, Sep 23, 2015.

  1. For as long as I've been playing RRRE I've always got the impression that the car tends to wave about making it difficult to control. I believe that other posters on the forum have noticed the same effect.

    Bear with me on this OK? I also play Stock Car Extreme which has a FFB EFFECTS option where you can choose FFB OFF LOW MEDIUM HIGH AND FULL. Most GSC resources recommend setting FFB EFFECTS to LOW with a G27.

    Although there are lots of FFB settings to fiddle with in RRRE I haven't been able to dial out the wavy handling, until now. I was poking around the "Logitech G27 Paddle Shift.rcs" control set file and I found this line

    FFB Effects Level="1" // Number of FFB effects to use: 0=No Effects, 1=Low, 2=Medium, 3=High, 4=Full, 5=Custom (identical to SCE).

    Mine was set to 4 or 5 (can't remember sorry), anyway I changed the value to "1" and voila, I can now race without feeling that the car is constantly waving around from side to side. This has certainly made a big difference for me and now I will be enjoying the game like I've always wanted to. By changing FFB EFFECTS to "1" it takes out most of the "canned" effects which aren't needed with a G27. All the FFB effects are still there, grip, sliding, kerbs, bumps etc.

    In game the only FFB settings I have changed are FFB Intensity 50% and Shift Effect 20% I now have a good basic FFB feel to play with.

    Hope this is useful to all you G27 users out there with the same wavy feeling.


    Glygoo PC Spec
    Gigabyte ATI Radeon HD 7870 OC Windforce 3X 2048MB GDDR5 PCI-Express Graphics Card
    Logitech G27 Racing Wheel
    Gigabyte 990FXA-UD3 AMD 990FX (Socket AM3+) DDR3 Motherboard
    Microsoft Windows 10 Home 64-Bit
    AMD Bulldozer FX-4 Quad Core 4100 Black Edition 3.60Ghz (Socket AM3+) Processor
    Antec High Current Gamer 620W '80 Plus Bronze' Power Supply
    Samsung Green (MV-3V4G3D/US) 8GB (2x4GB) DDR3 PC3-12800C11 1600MHz 30nm Dual Channel Kit
    Cooler Master Hyper TX3 Evo CPU Cooler
    Samsung SpinPoint F3 1TB SATA-II 32MB Cache
    Antec 302 Three Hundred Two Ultimate Gaming Case - Black
    • Like Like x 5
    • Agree Agree x 2
    • Beer Beer x 1
  2. Nox

    Staff Premium Member

    I have a G27 and I too suffer from crappy unfinished FFB. A number of people have mentioned it, but as yet there's been no sign of a fix. I know it is still officially a beta, but it seems a huge oversight to ignore users with such a common wheel. Most of their effort seems to go into new tracks like Paul Ricard, Spa, Nords, etc, to make more money, but no real effort on the G27 FFB. Spa looks great, but if I can't drive a straight line on it, what's the point? And if I sound frustrated it is because it was a fight even to get them to admit there was a FFB issue, and it has been like this for a very long time. I do appreciate your suggestion, I've tried it and S3s suggestions from other threads, but it isn't good enough and the wheel still swings back and forth. I'm avoiding R3E until they fix it, and if they don't, well they'll lose a paying customer.
    Last edited: Sep 24, 2015
    • Agree Agree x 4
  3. I'm surprised it hasn't made any difference because mine is totally fixed. You may already know this, but you need to edit the "Logitech G27 Paddle Shift.rcs" file, then in the game select the G27 controller profile then enter your personal wheel settings. It won't work unless you create a new profile after editing the.rcs. If you've already done this sorry it didn't work for you. Since I changed mine I can attack the race track instead of tiptoeing around waiting for my car to spin off.

    • Love Love x 1
  4. Vangelis pargiNOS

    Vangelis pargiNOS
    Do your best, today!!! Premium Member

    Cant find that line in my Logitech G27 Paddle Shift.rcs
    Thx anyway

    Edit: Found it sorry, i will try and report ;)
    • Like Like x 1
  5. Lars Hansen

    Lars Hansen
    RDs Ion-Engine....0-60 in six days. Staff Premium Member

    Absolutely brilliant tip.
    Easy to implement, and oh boy does it work wonders. :)
    • Like Like x 1
  6. BoogerMac

    Premium Member

    Nice find...I'll try this later tonight.
  7. Jake Fangio

    Jake Fangio
    Please don't rain pleeaassee don't rain

    Yes can confirm this fix. Great job mate.
    • Like Like x 1
  8. Georg Ortner

    Georg Ortner
    Sector3 Studios Premium Member

    Everything this line does can be achieved through changing the settings via the menus.
    Disable engine and brake vibrations / shift effect, and set dampers + friction to 0.

    FFB Effects level 1 - 4:
    1 = SteerForce
    2 = Steerforce + SteerFriction + Damper + Jolt + Rumblestrip
    3 = Steerforce + SteerFriction + Damper + Jolt + Rumblestrip + BrakeVibe
    4 = Steerforce + SteerFriction + Damper + Jolt + Rumblestrip + BrakeVibe + ThrottleVibe
    You have to make sure, that you checked the box "allow game to change settings" in the logitech profiler though.
    • Beer Beer x 2
    • Like Like x 1
  9. Kenny Paton

    Kenny Paton
    Backmarker Champion 2015 & so far this year. Staff Premium Member

    What happens if you don't use the profiler?
  10. SOLO59

    Premium Member

    This is a great find. Works really good. Don't forget to create a new profile in game. Thank you @Glygoo
    • Like Like x 1
    • Agree Agree x 1
  11. BoogerMac

    Premium Member

    Yes, great find @Glygoo. I played for a few hours the past few days and your "fix" worked wonderfully. Thanks!
    • Like Like x 1
  12. Georg, I wonder what they're feeling then? Is SteerFriction + Damper creating the "boat sway" effect?

    I'm running an AccuForce and have been finding that *increasing* friction alleviates the issue for me although not completely.

    Previously my Friction and Damper were 0% and I increased them to *reduce* boat sway.

    What do you think we're feeling?
    • Like Like x 1
  13. Unfortunately the setting didn't work for me :( I didn't find it in the RCS file, so I added it manually, but still got quite a bit of boat sway. I'm not sure it was even accepted. When I exited R3E the file no longer had that setting in it.

    For anyone interested, I've been recording my latest settings on my blog here, with settings screen snaps:


    My latest tweaks involve adding damper and friction which, for wheels with some force to spare, really increases the realism of how much effort it takes to move the wheel. Friction also seems to alleviate the wild backend whip-tail behaviour which I think is due to the Understeer having nothing to slow it down when Friction is at 0% (which it was defaulted to for me).
  14. PaulH

    Premium Member

    This also worked for me using Thrustmaster TX, made hell of a difference :thumbsup:
  15. You should be able to find the .rcs in first image, then edit the highlighted line in second image.
  16. xnorb

    Premium Member

    Interesting - will check it out when i come home.

    EDIT: Didn't help anything.
    But i still doubt that it's an FFB problem to begin with...
    Last edited: Oct 5, 2015
  17. Thanks, I was editing the right file (I have other edits in the file) but that line wasn't there.
  18. Msportdan

    @ Simberia @Simberia

    id love to try rre again, but the boat swaying/over powerful centre spring, eventually put me off this game. Will this thread fix it on a t300 gte?
  19. Brandon Wright

    Brandon Wright
    I'm just here for the snacks

    It didn't on mine, though I didn't edit the text file and just followed Georg's advice above by disabling engine and brake vibrations / shift effect, and set dampers + friction to 0. It felt better, but still floaty and still too much center spring.
  20. Emerson Meyer

    Emerson Meyer
    Keep Fighting Premium Member

    Interesting. The devs never acknowledge the FFB had issues...
    And now they are talking about fix it.

    Well, better later than never.