1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Steam is being a pain again

Discussion in 'Presto GP' started by Jim Hawley, Aug 27, 2013.

  1. Jim Hawley

    Jim Hawley
    PrestoGP Veteran

    A while back steam decided to give me an extra race07 folder (install 2), I didn't touch anything it just did, this has caused me issues with skins and other stuff

    Last night when I tried to launch the game it came up "failed to launch-missing exe" so I did what steam recommended (exit/delete appcache/restart etc) and it worked, I was able to run some laps at Spa, tonight it did the same thing but the fix won't work?

    I'm currently validating game cache and updating as req, don't know if this is going to work yet

    Anyone else been cursing Steam as much as I have lately?

    Jim

    Edit: "I'm currently validating game cache and updating" this appears to have worked, but for how long:unsure:
     
    Last edited: Aug 27, 2013
    • Like Like x 2
    • Beer Beer x 1
  2. David Turnbull

    David Turnbull
    PrestoGP Veteran

    not had any problems with steam lately jim, i remember the problems that your on about though, i just reinstalled everything once steam got its act together and sorted the file system back out, been fine since (touch wood)
     
    • Like Like x 2
  3. Dino Paolini

    Dino Paolini
    Premium Member

    • Like Like x 2
  4. Dino Paolini

    Dino Paolini
    Premium Member

    • Like Like x 1
  5. FFS!!! Not again...Mental note to myself: remember to start gamerig, do not start steam and copy all CGF files to somewhere safe... Only good things is that the race is not today, we got (probably ) enough time to reinstall everything, i'm not gonna even try to do it manually this time..
     
    • Like Like x 2
  6. Peter Decker

    Peter Decker
    PrestoGP Veteran

    I just couldnt start the game - the video config windows popped up with only the graphic card to chose. The other list boxes were blank and no button worked for closing it.

    Tried diabling XD as before when the same has happened, but ended up deleting all mods and everything through steam (after taking backups of all settings etc.). When I tried validating, I got the message about making it more efficient bla bla. So I killed Steam, since nothing happened. Then started it again, chose to install the now uninstalled race07 and, yeah I guess it got "more efficient" anyway, in the common-folder.

    Now it works, however.
     
    • Like Like x 2
  7. The GT club class has gone missing and the XD lapdelta does not work anymore. At least F3000 still works properly :)

    edit: Ah the XD.ini has been reset so thats the lapdelta thing
     
    • Like Like x 2
  8. It screwed me over too just before the race, but got it fixed in time (barely) by
    1) Delete desktop shortcut
    2) going into the steam folder and manually running the config program to reset the graphics resolution
    3) create new desktop shortcut and drag to desktop
    4) in the documents/simbin/ folder you will see a new folder called Race07 install2 or something like that. Go into the original Race07 folder and select all and copy. then go to the install2 folder and paste and say OK to overwriting. Now all your settings/config and setup will be restored.

    I also had to reinstall the no visor fix in the Gamedata/teams folder
     
    • Like Like x 4
  9. Dino Paolini

    Dino Paolini
    Premium Member

    I did uninstalll all expansions manually and did a backup of my Profile.

    Than installed everything again and put the entire profile back in.

    I took about an hour, mostly because of the download time of the expansions, but atleast everything works now and I got a cleanup of all mods I wasn't going to use anymore anyway :D
     
    • Like Like x 4
  10. I backed up my files, answerd yes to converting (or whatever they called it), allowed it to complete, copied my profile (folder called Nicolai Nicholson), and my skins, and voila, it seems to work fine. This took me 15 minutes.
     
    • Like Like x 3
  11. they are determined to make a shrinking game shrink more...no wonder its hard to find new blood.it is so tiresome...
     
    • Like Like x 2
  12. Did you had to convert every expansion pack before it worked?? Where did you copy your profile??? Nothing works for me and i read so many different things here that i'm confused on what to do.... grrrr i hate that!!
     
    • Like Like x 5
  13. Valter Ostman

    Valter Ostman
    PrestoGP Veteran

    I do not understand the point of repairing something that works so that it does not work. After every Steam update which resulted in SimBin games did not work, no noticeable improvement of the game occurred. Why then this eternal updating?
     
    • Like Like x 6
  14. Edit: Sorry i made some serious mistakes in this replay, corrections are in red. I guess i was too sick about steam !!

    I manage to fix the game. I don't know why but i now have all my folders and files in steamapps/common/race07. for it to work. I need to put any new skins and mods in document/simbin/race07 unstall2 instead of old: documents/simbin/race07. I was missing config.exe in steamapps/common/race07, so i copy it for steamapps/my profile/race07 to common/race07, and adjust the resolution correctly (1920x1080 32bits for me) and then the game start.

    For unknow reason i now have documents/simbin/race07, race07 install2, race07 install3 and race07 install4...... as it works i thought i'll leave them there.... but WTF ???

    Steeve
     
    Last edited: Aug 30, 2013
    • Like Like x 4
  15. Sean Greenlaw

    Sean Greenlaw
    PrestoGP Veteran

    Noooooo sat in rig to play not again :thumbsdown: lol no doubt they will swap back on race day:mad:
     
  16. No, this the final change. After this there will be no changes to filestructure, Race07 was the last title in the whole Steam catalog to be converted..
     
    • Like Like x 2
  17. Sean Greenlaw

    Sean Greenlaw
    PrestoGP Veteran

    They did the same thing not long ago with race 07 to comman folder then reverted back again, never say never :thumbsup: im sure they thought that was last time previously lol
     
    • Like Like x 2
  18. Can't say how i know but trust me on this.. The first time it happened, it was a scheduling mistake.. Steam was completely at fault so instead Race07 was scheduled as last one to give us more time.. If it were to happen when it was scheduled, we would've been too pissed about it.. to have our game converted mere weeks apart from old to new to old to new..

    Noticed that fastest way was to backup my docs\simbin}rac07 folders, wipe the whole game out and download everything. That cause if you convert existing, it got no queuing, takes longer per expansion (i have all of them..) and you have to be monitoring your pc to start the next conversion. With 50mb/s connection, downloading was faster.
     
    • Like Like x 3
  19. Damn, just started up game after hiatus - was ready to play and all this sh..t again. :(

    Everything locked up at 17% !!
    Gonna do like Kennett and reinstall everything..
     
    • Like Like x 1
  20. I have no idea what is wrong, every time I try to reinstall, Steam hangs.
    I try to exit it and it ends up "stopped responding" - i try to restart my computer and it wont even restart, my entire computer hangs. I have to manually force a shutdown.

    I have tried 7 times now with same result.
    Suddenly normal use of the computer makes it hang - this did not happen before I uninstalled and tried to reinstall.

    Everything is f'ed. Cannot practice today, and with UNI tomorrow I will probably not have time to reinstall everything (windows etc.).

    There is no virus or Spyware - this is checked every day.
    Do not use this computer for downloads, my NIC is updated - am at a loss what is wrong. Steam seems to be the culprit - although I cannot understand what it could do to my entire setup.

    Participating in race seems far away at this minute...:mad: