1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Steam: Fatal Error

Discussion in 'RACE 07 - Official WTCC Game' started by Alex Galyutin, Apr 30, 2010.

  1. I've just tried to start the game (GTR Evo).
    Run Steam... and after it was trying to log in, it said "Fatal Error: Failed to load platform modules."
    any tips guys? should I re-install all my SimBin games? :mad:
     
  2. Thank you Nico!
    now I'll try to repair Steam with help from your link!
     
  3. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Was this the first time you started steam after the platform update? THen it might be useful to reboot and then look and see if the steam.exe is still in place. Or did you solve it already?
     
  4. I've tried what was told on Nico's link. It did not help...

    Bram, I don't know if it was the first time after the platform update. Yesterday I played online, everything was ok. Then Steam updated itself and asked for restart. I declined, because decided that there would be nothing terrible to restart Steam lately. And today Steam can't be run.
     
  5. Alex, I had the same problem. The solution Steam provided in their knowledgebase was useless to me (the link Nicolai sent). I solved it by deleting the ClientRegistry.blob file in your Steam folder. The moment I deleted it, I restarted Steam, and it updated itself, and the problem was solved. Try it...
     
  6. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Please note when you delete both the .blob files you are asked to fill in your password again. Make sure you have it :)
     
  7. Had the same problem. Delete steam.dll from your steam directory, forcing it to update itself the next time you launch Steam. Hope it works, it did for me.
     
  8. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium Member

    only happens for me on the netbook. thanks for the fix Eric.
     
  9. Thank you all guys!
    I deleted ClientRegistry.blob file, and Steam updated itself normally and now works fine. I haven't tried if the games work yet, but guess everything is ok now.
    Thanks again!
     
  10. hey guys


    i had the same problem, but did what you guys suggested and it seems to be working fine.

    thanks alot!!!!
     
  11. Had the same , did system restore and put it 2 days back.After that Steam update went well.
     
  12. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Not needed :) Just delete the two .blobs :)
     
  13. Hannu Karesola

    Hannu Karesola
    Premium Member

    Steam.dll delete worked for me, thanks!