1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Steam crashes in time attack

Discussion in 'RACE 07 - Official WTCC Game' started by Krister Larsson, Feb 18, 2008.

  1. I've suddenly got a Steam problem just running Time Attack using custom skins that I've traced down to the path length to where the skin files are.

    I've a structure like this under Customskins

    - Blue Flag Racing
    -- Gentlemen Racers
    --- 43 - Krister Larsson

    All the skin files for myself are in the "43 - Krister Larsson" folder. This causes Steam to crash each time I go into Time Attack but not else.

    I tried moving the files around and shortening the path down to

    - BFR
    -- 43 - Krister Larsson

    and this makes it work. If I just change the name of the folder BFR to "Blue Flag Racing" (or something slightly longer than BFR) Steam crasches again when going into Time Attack. I've not seen this problem earlier so I guess it got introduced by some of the latest patches.

    The problem has also been reproduced at another PC installation with another skins structure so it's not just my PC that's got this problem.

    RSC come back on line so I can report it!
     
  2. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Do you have some mini dumpfiles to attach Krister?
     
  3. Warren Dawes

    Warren Dawes
    Premium Member

    I doubt that this problem is related to the latest patches. I have experienced this previously with TA and custom skins. Some work and some don't.
    I put it down to something to do with the file structure or types of files used in creating the skin, but what would I know. Krister, if it is any help I could send you one of my skins that don't work and one that does, maybe you can see something in them that helps.
     
  4. Yes, I do have minidumps and was going to put them on RSC when back on line. I'll update my post tonight attaching a dump.

    No it's not related to a particular skin but rather to the length of the path where the DDS files are. I had a go with BFR collegue Kent last night and asked him to try it with a local old skin he had. Steam crashed when he tried Time Attack. He then moved the files up one level and stil had a problem. He then shortened the name of the folder and then it worked. So it's related to the length (number of characters) in the total file path to where the skin files are..

    I also had skins working but by moving them one folder down they stopped working causing Steam to die when going into Time Attach. It seems to be related to where it starts loading the dds file. I've had anything but just one entry in the ini-file with a ref to a dds-file and that don't work. If I just have refs to the TGA-files I have no problem.

    @Warren, yes you can send me the skins working and not working and I will have a look at it. But be sure to give me the path to where you have stored them under Customskins. Or you could try moving the skins not working to a folder with a very short name (like X) just below Customskins. Unless the dds-files have very long file names this might solve your problem.
     
  5. Warren Dawes

    Warren Dawes
    Premium Member

    Seems like you are on the right track Krister.
    I had two chevy skins:
    1. Simjunkies Team - Longer file path and more characters
    2. RPM Team - Shorter path

    The RPM skin was OK and the SimJunkies skin crashed in TA.

    I shortened the name of the SimJunkies file and reduced the path length as you suggested and bingo it worked.

    In fact, just keeping the same folder name but shortening the path was ok.

    Cant get a more clear cut example than that.
    At least you solved my problem and have found a work around, but Simbin need to resolve this permanently.
     
  6. Seems like we've got a conclusion on what's the problem. There is probably an exact limit in the total file path character string lenght where the problem happens. But I hand that over to Simbin to look up in the code rather than finding it out myself by crashing/changing/restarting over and over again to find it. Restarting Race07 over and over again is not that funny...:sad:

    @Bram, do you still think Simbin will need the dump file and how will they get informed about the problem and the findings we have?
     
  7. It sounds like Simbin has stayed to the "standard" 255 max character length that has limited windows in many cases in the past. If this is the case, even a simple name change on the dds file itself may help resolve this issues, but it would all depend on exactly how long your total path is.

    My suggestion would be to simply keep things in the minimum number of subfolders that you have to in order to keep things organized, and don't get too elaborate in the naming. The old "KISS" method seems to be the appropriate way to ensure that TA will work with all your custom skins.

    (Note: KISS stands for Keep It Simple Silly, though the last S tends to be interpreted in many different ways, :) )
     
  8. Dump file

    Attach is a Steam dump produced by the setup described in the top post.
     

    Attached Files:

  9. I have several Minidumps.. Was trying a LAN game last night on some tracks. using 1987 cars (some 'addon skins') but Some tracks I could not join and others it would crash/dump once entered the track. The odd 'addon' tracks did work.
    My brothers laptop crashed on occasions trying to go into 'control setup'.
    I've deleted most of the mods and some of the add on skins but still problems.
    I'm unsure what in the minidump file would tell me what mod/skin/track etc is the root of the problem???
    I have a program that can open dump files but the data with in the file, nothing i can see means much sense.
     
  10. ive had an errors only in timetrial mode too. i cant see my car at all in any view and get no sound either. its happened many times but have no clue what this is caused by. any ideas?
     
  11. I have a similar problem with evolution crashing as i crossed the line in timetrial mode @ Puebla Oval with the FBMW cars but if i start the game with race07 instead then it runs no problem.
    weird or what ?
     
  12. I had same the problem , only GTR-E can't TA ....use RACE 07 , STCC run TA or on line is no problem .

    I had delete the .blob files and relogin until update steam but can't fix...

    I also use command write minidump file but can't fix...