• "I've tried everything other than jumping out of a plane, but nothing gives you an adrenaline rush like racing a car." - Nigel Mansell
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SimRaceway SRW-S1 keeps disconnecting

Discussion in 'Sim Racing Hardware' started by Kuba Brzeziński, Dec 13, 2013.

  1. Kuba Brzeziński

    Kuba Brzeziński
    Premium

    Messages:
    124
    Ratings:
    +65
    I've got a problem with my Simraceway wheel. I moded it with my G25 and it worked fine, but it's been disconnecting for the past few days. I mean, it is connected via USB, but when I'm driving it disconnects for a couple of seconds and then it works again. Any solution?
     
  2. Alex Brumpton

    Alex Brumpton

    Messages:
    135
    Ratings:
    +35
    I had this issue with my first SRW-S1, eventually it died, the circuit board inside the unit malfunctioned... so I had it replaced and iv had the one I have now for coming 5 months with no issues. I modded mine on my G27 with a simulaje quick release system (with this one I make sure my SRW-S1 is attached to my G27 base before plugging in the USBs for it and the G27). Is it disconnecting on all of your games? or just a single one, because I heard with rF2 before it was fixed that it would disconnect a controller if you had multiple plugged in.
     
  3. Kuba Brzeziński

    Kuba Brzeziński
    Premium

    Messages:
    124
    Ratings:
    +65
    Disconnects both at rFactor and F1 2013. Restarting computer seems to help. After restart it may disconnect once and then it's ok. So did you have it replaced for free?
     
  4. Alex Brumpton

    Alex Brumpton

    Messages:
    135
    Ratings:
    +35
    No I couldn't send it back for a replacement due to me having modded it to work with the Simulaje quick release system, I just bought a new one £45 at time of purchase (Cheapest iv ever seen it).