1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Shadow flickering problems GSC Extreme

Discussion in 'Stock Car Extreme' started by Franklin Stegink, Apr 8, 2015.

  1. Franklin Stegink

    Franklin Stegink
    Premium Member

    Hello,

    Sometimes i have problems with shadow flickerings problems in game.
    I have a nvidia GeForce GTX 680.

    In my nvidia configuration i have set my settings on quality.

    [​IMG]

    In game i have set everything on max.

    Suddenly when i am in game my shadows are gonna flickering.
    When i push ALT+TAB and go after that back in game its solved.

    This is my system:

    [​IMG]

    When i put in game the shadows to high, the special effects to high and shadowblur on off it is oke.

    Everybody else with this problem, and if so is there a solution?
     
    • Like Like x 1
  2. I also encounter this issue, with the latest v1.3, which I reported in the same update announcement thread, but got no reply at all regarding it. I use a GTX970 and high settings. Though I don't get any FPS issues, just this annoying flickering.
     
    • Like Like x 1
  3. Same issue here, it is a common problem.
     
    • Like Like x 1
  4. Lazarou

    Lazarou
    Premium Member

    I also have had this issue on a 660Ti It was okay for me before the updates after steam release now it is back!
     
    • Like Like x 1
  5. Renato Simioni

    Renato Simioni
    Reiza Studios

    We had this issue in one of our testing rigs, never figured the cause but I seem to recall this being corrected by setting shader level from auto to DX9 (or from DX9 to auto, not sure which). That setting has no other side effect.

    Also does not seem to occur when running SweetFX for some reason.

    Assuming what you guys are seeing are shadow artifacts like the pic attatched.
     

    Attached Files:

    • Like Like x 1
  6. Falk Massmann

    Falk Massmann
    Premium Member

    Hi Renato,

    that´s exactly the problem in your image. I´m having the same problem. I had a GTX670 before and switched to a GTX970 recently. The issue seems to appear only on nvidia hardware. Last club race I was asking around and people with AMD graphics cards don´t seem to have the issue.
    Unfortunately I´m using the Reiza SweetFX package and it is still happening.
    5 or 6 months ago I already asked for a solution and someone from Reiza suggested to use -fullproc with the shortcut for the executable. Haven´t tried that yet but will check again.
    Besides this issue SCE is running great, pulling almost 200 fps with 24 cars on track :thumbsup::inlove:
    Hope we can get to the ground of the problem.

    Cheers
     
  7. Franklin Stegink

    Franklin Stegink
    Premium Member

    Indeed Renato,

    Thats what happens.
    My FPS is almost 300 with full grid and all settings on max.

    In my GSC Config i have Quality (DX9) and anti aliasing at 8.
     
  8. Renato Simioni

    Renato Simioni
    Reiza Studios

    Creating a shortcut for the executable, adding -fullproc to the command line and running the game from it is also (in my experience) a sure way to prevent the issue from raising its ugly head, but that will naturally also limit your performance.

    I suggest switching shader level to AUTO, see if that helps.
     
  9. I tried it last night, from Auto to dx9, and the flicker didn't appear, at least in 1 car/track combo. Will try more when I get the chance to play the game more.

    Why would fullproc limit performance? Thought this should even optimize cpu usage?
     
  10. Tried another track earlier and flickering seems gone. I found I no longer see replays, where again can I find the setting for this to appear? Thanks.
     
  11. Renato Simioni

    Renato Simioni
    Reiza Studios

    +fullproc optimizes CPU usage, and that has been built into the exe since v1.15. By adding -fullproc you are disabling optimal CPU usage.

    Regarding replays, check the replay menus to see if recording is activated, and your controller mapping to see what key is set for instant replays.
     
  12. Oh right, thanks. When I posted I was actually thinking the minus sign in -fullproc as a pre-parameter, and not as a negation. Upon checking mine had +fullproc. So I actually can just remove the sign, as it's already built-in.

    I'll check about replay, thanks again.