1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

SColNodeEX::Split failed!

Discussion in 'Bob's Track Builder' started by martinez, Oct 19, 2010.

  1. Hi!
    While loading a track, RBR says the error message and does not answer.
    Any clues? Everything seems to be fine... Where should I search - track nodes, road profiles, terrain vertex, track anchors? Thanks in advance
     
  2. I got the same message a week ago. May be it has the same origin:

    Look for 2 "track surfaces" on the same position. Just use the arrows on the top-right corner of the surface's pop-up window to jump from one to another and if you see no jump then you know you have 2 surfaces starting exactly on the same place.
     
  3. Yes, it was :) I don't know, how he (btb) did it... But I know one thing for sure: Zaxxon, you are truly master! Thanks a lot! :)
     
  4. Now I have the same problem :( SColNodeEX::Split failed....
    I have look for 2 "track surfaces" on the same position. like Zaxxon said
    but it does not help :(
    Please help. I have worked a lot with my project
     
  5. You could try the same for walls if they also have a change of material.
     
  6. I have this issue (for the second time now) again! Maybe earlier I hade the DumpNode failure, which I solved nicely by deleting a track surface that was too close to another. Now, on the other hand, there is no track surface nor wall surface that appear to be incorrect. Everything worked great on the track until I changed object properties for a few Objects/SObjects... Anyone have a clue? Could it relate to something else than walls/tracks?

    EDIT: I have now been able to solve it thanks to Brendon! Many thanks for helping me out! It appears the SColNodeEx::Split failed is NOT only related to walls, but rather to polygons that are too small. In my case it was a pole I had placed out that I accidentally rescaled so it had an infinite thinness. That meant, when RBR was to load the track the polygons of the object were too small and it ended up with the error message. I could locate the object and delete it thankfully, and now it works again! Thought I would share this with you to add to the troubleshooting process! Look for objects that have too small polygons aswell!
     
    Last edited: Jan 30, 2014