• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

S3 forum extremely slow

Discussion in 'RaceRoom Racing Experience' started by Boby Kim, Jul 6, 2016.

  1. Boby Kim

    Boby Kim

    Messages:
    1,112
    Ratings:
    +342
    HI peeps,
    Since a week the S3 forum is extremely slow and or the site wil not pop up. Im using Firefox but the same problems happens with IE and Chrome. Anybody else having this problem?
     
  2. William Wester

    William Wester
    Premium

    Messages:
    1,190
    Ratings:
    +443
    I haven't noticed any slowdowns, I visit daily.
     
  3. Christian Moreau

    Christian Moreau
    A disgruntled hedgehog thing... Premium

    Messages:
    2,352
    Ratings:
    +1,575
    No issues here. Maybe try clearing your cache on all the browsers? Another thing you could try is using a VPN in case your current IP address is being filtered somehow.
     
    Last edited: Jul 6, 2016
  4. Boby Kim

    Boby Kim

    Messages:
    1,112
    Ratings:
    +342
    Thanks peeps, will dig deeper into the problem. Cheers:thumbsup:
     
  5. Boby Kim

    Boby Kim

    Messages:
    1,112
    Ratings:
    +342
    It's strange...when I visit the S3 forum it's fast as other forums until I try to login in. Same problem occurs when logging via my phone, I mac, pc with different browsers.
    It slowed down after I criticised S3 about the lack of response to questions. Maybe I stepped on someone's toe.