1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RX plugin not loading

Discussion in 'Richard Burns Rally' started by Jim Simeon, Mar 1, 2014.

  1. Has anyone else experienced this issue before? I have RBR on two computers, both win7 sp1. For some reason the rx plugin won't load on this particular machine. I've tried a clean install of RBR and that did not help. Also tried installing the latest DX9.0c drivers with no success.

    I've attached the DxDiag info here.

    Attached Files:

  2. Can't say I have. What do mean exactly by rx_plugin not loading? Can't you access it via RBR menu (Options --> Plugins)? What is the pack you're using to install rx_plugin to a clean install? Maybe you don't have all the necessary files, and I would recommend using this pack: https://www.dropbox.com/sh/macmdh4i...UGIN COPY THIS FILES IN RBR INSTALL FOLDER.7z.

    I like how you've installed DirectX 9.0c, somehow I don't believe there are too many people with Win7 who could say the same. :)
  3. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    Now I got curious! What do you mean with that? :)
  4. Well, I made a rough estimate that most people may not have realised that their Win7 may not have DirectX 9.0c included, that's all there was to it. A tedious thing really, but I needed a sentence in there with some words and that was what came out. ;-)
  5. I meant to say that it was missing from the options -> plugin menu in RBR. I installed it via the latest Bobstrackbuilder release. The issue seemed to resolve itself while i was installing the pre-reqs for directx debugging.

    This included the directx 9 sdk: http://www.microsoft.com/en-us/download/details.aspx?id=6812, and the windows sdk: http://blogs.msdn.com/b/chuckw/archive/2012/11/14/directx-11-1-and-windows-7.aspx. i finally got directx into debug mode, and when i ran RBR again, everything showed up properly.

    My guess is between installing the directx sdk files, the windows sdk, and visual studio, the correct dx drivers were installed and potentially corrupt ones were overwritten, resolving the missing plugin problem.