• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Rift FPS no higher than 45ps

Discussion in 'Assetto Corsa' started by Paul Glover, Aug 29, 2017.

  1. Paul Glover

    Paul Glover
    Joker Premium

    Messages:
    707
    Ratings:
    +419
    I'm not one who pays attention to fps, maybe I should. It dawned on me that I had never checked the 'performance' and I've realised AC will not go over 45fps.

    I've done quick search and checked a few things on RD and the internet but nothing seems to help improve it, I am running the Oculus tray tool.

    Specs are ok I think?

    Intel Core i7 3820
    16.0GB DDR3
    GeForce GTX 1060

    Any help much appreciated

    Paul
     
  2. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,087
    Ratings:
    +779
    I have no VR so I can't really help but what I do know is that my overclocked I7 2600k at 4.4 GHz runs with over 100 fps in AC without any apps activated but when I go with full telemetry into a race it drops down to mid 40's!

    It seems that apps are really heavy on the fps. My CPU load isn't high, it just slows the game engine down...

    So try to deactivate every app. Not just make them not visible, deactivate them in the launcher or content manager and see if you can reach the 90 fps :)

    I changed my complete hud because of that :(
     
    • Like Like x 1
    • Agree Agree x 1
  3. RipVanWinkle

    RipVanWinkle

    Messages:
    1
    Ratings:
    +1
    Do you use the oculus tray tool? If not it's a free program that has a lot of good uses. One of the things you can do with it is disable ASW mode. I do this for all racing games. ASW limits fps to 45 in the rift which can be helpful with some games for Oculus but for sim racing it isn't. I imagine if you disable your ASW you'll be able to see what your actual frame rate is and be able to adjust your settings from there to hit 90.

    The tray tool also allows you to multisample from the tool instead of having to change the oculus.ini as well.
     
    • Like Like x 1
  4. bloozmahn

    bloozmahn
    Premium

    Messages:
    139
    Ratings:
    +58
    my system is much less powerful and it runs better than that. i'd check asw, and you do have to pick graphics settings carefully as some things really affect performance compared to others.
     
    • Like Like x 1
  5. DowntownSIX

    DowntownSIX
    Premium

    Messages:
    153
    Ratings:
    +156
    The 45fps value is due to ASW (Asynchronus Spacewarp). It's a feature of Oculus and works in a similar way to Vsync in that when it cannot reach the magical 90fps it defaults to a maximum of 45fps and interpolates every second frame to make the image appear smoother. You'll see that in every game.

    I had the same issue - it seems AC has a problem rendering post processing effects in VR. Switching those completely off gave me a huge FPS boost and got me over the ASW magic 45fps and I now maintain a solid 90fps everywhere.

    Fore reference, I'm on Oculus running an i7 and 1080Ti.

    Note - there is an Oculus debug tool that allows you to switch on a performance HUD. It shows a bunch of things but most importantly, a 'performance headroom' percentage which is great for dialling in your settings to ensure you maintain the magic 90fps.
     
    Last edited: Aug 30, 2017
    • Agree Agree x 3
    • Like Like x 1
  6. Terry Rock

    Terry Rock

    Messages:
    1,062
    Ratings:
    +359
    You are running the exact same processor I'm running.
    DT6 is correct.
    Turn off PP filters.
     
    • Like Like x 1
  7. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    Yeah, PP consumes some significant resources. Only reason I use it is to have a better visual of brake lights of cars ahead.
     
    • Like Like x 1
  8. DowntownSIX

    DowntownSIX
    Premium

    Messages:
    153
    Ratings:
    +156
    I thought I was having trouble seeing brake lights in VR, must be the PP. Thanks for the heads up.
     
    • Like Like x 1