• "I'm going to pee in your seat" - Jenson Button
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. The 2017 Formula One Monaco Grand Prix. Join the conversation here.
  3. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

rfactor2 tearing problems

Discussion in 'rFactor 2' started by kamackeris, Sep 22, 2015.

  1. kamackeris

    kamackeris
    Premium

    Messages:
    1,469
    Ratings:
    +576
    been playing bathurst fine with 30 ai and no tearing, but since the update bathurst and the updated to the geforce drivers i'm getting really annoying tearing. any help guys ??
     
  2. Emery

    Emery

    Messages:
    897
    Ratings:
    +217
    Roll back the GeForce drivers? If it was working fine before, why update?

    Were you using V-sync before and turned it off when you updated? V-sync introduces significant lag, but eliminates tearing.

    Were you using NVidia's G-sync before and turned it off when you updated? G-sync requires a compatible monitor, adds a little lag, but should eliminate tearing.

    Were you using a max framerate before and turned it off or changed the value? Setting the max framerate in rF2 to the screen's refresh rate reduces tearing, but won't eliminate it, however there's no lag introduced.
     
  3. kamackeris

    kamackeris
    Premium

    Messages:
    1,469
    Ratings:
    +576
    i have gone back a couple of drivers and still the problem. always had v sync off. i don't have a g sync monitor (don't know what one is tbh). i had the max framerate set at 60 before
     
  4. Dino Paolini

    Dino Paolini
    Premium

    Messages:
    1,349
    Ratings:
    +1,731
    Try a framecap that is slightly off, like 59.
    Also look if something has changed in your "video settings" in the launcher maybe