1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rFactor randomly stops working

Discussion in 'rFactor' started by diago226, Apr 8, 2015.

  1. i have rFactor on steam, i have a windows 8.1 64-bit system with a 4770K, 16gb ram and a gtx 780, i just cant for the life of me figure out why it keeps crashing!!! also! my start up time for the game alone is 6+ minutes! please help me resolve these issues!
  2. Erwin Greven

    Erwin Greven
    Premium Member

    I do not know why you got these problems, but i have also issues with rfactor since it is on steam.
    I use normally 2 screens but rfactor refuses to start with 2 screens on. With one screen working it works.
  3. @diago226 it definitely sounds that something is wrong with your system. I have a system that is similar to yours (except that I run Windows 7 64 bit):
    • Intel Core i7 4770K @ 3.5 GHz, 8 MB cache
    • Gigabyte GV-N780GHZ-3GD GeForce GTX 780, 3 GB GDDR5
    And starting up rFactor (I have an SSD but it should not be that much slower on a HDD) should be done within 30 seconds or less. I suspect it is either a "permission" problem (try running as Administrator or otherwise make sure you have sufficient permissions) or a virus checker that is interfering with the loading of files.

    @Erwin Greven do you have any further diagnostics that could help us figure out what is wrong? You say it refuses to start. Do you get any message? Does anything happen? Can you try launching rFactor with "trace=3" as a command line option? Can you try disabling the Steam overlay?
  4. @Marcel Offermans i have a SSD also, and my permission are all set to run as admin, with win xp sp3 compatibility.
  5. The game it self will load but t sits at a black screen for several minutes.
  6. Can you try launching with "trace=3" and posting the trace.txt that you get from that? Maybe that gives us a hint about what's wrong.
  7. Erwin Greven

    Erwin Greven
    Premium Member

    I launch the program from rFactor.exe without the Steam overlay. I try to prevent to go into steam as much as i can. Without the second screen it loads without any problems. When i add the second screen, it simply does nothing, only in taskmanager rfactor.exe is to be seen.
  8. So you're not launching it from the Steam Client, but directly launching rFactor.exe, fair enough. I could tell you that technically it will reach out to the Steam Client anyway, because of the Steam integration and for DRM checks, so it really makes little difference, but that won't solve your problem. Steam overlay is something different from the client. You probably have seen it, but it really is an overlay over your application. Disabling it is what Steam recommends in case of problems, which is why I'm asking. You can disable it in the Steam Client. Please try that. And also try the "trace=3" and post the output here. Just stating it does nothing does not help me diagnose the problem (as I cannot reproduce your issue on my system).
  9. Erwin Greven

    Erwin Greven
    Premium Member

    I don't know where to put "trace=3"
  10. It is a command line option, that you can put behind rFactor.exe when you make a shortcut and edit that. When you do that you get a trace.txt file in the UserData\Log folder. Sometimes, that file gives you a hint about what is not working.

    At the same time, I would start with disabling the Steam Overlay option in the Steam Client.
    • Agree Agree x 1