1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

rFactor 2 launch problems

Discussion in 'rFactor 2' started by johnnymat, Jan 24, 2017.

  1. johnnymat

    johnnymat

    Messages:
    229
    Ratings:
    +61
    After an absence of several months, I've tried playing rF2 and it won't launch. The version I have is the Steam version.
    I can't think of any updates, other than GPU drivers, that I've made recently.
    When I last played it, it worked fine with Windows 10.
    I uninstalled it and also verified the integrity of the game files and it appears to be o.k.
    When I try to launch the game, the screen just stays dark and nothing happens. When I press the Windows key or hit "alt, ctrl, del", I get an error message that says "error creating vertex shader."
    Any help would be greatly appreciated. Thank you.
     
  2. Gijs van Elderen

    Gijs van Elderen
    Premium

    Messages:
    4,571
    Ratings:
    +2,358
    Delete all files in:
    rFactor 2/UserData/log/Shaders
    rFactor 2/UserData/log/CBash

    New shaders will be created based on your graphic settings.

    Shaders aren't part of the "core" game. They are created based in your graphic settings and coreshaders.
    So stay with ingame graphic settings and a default Nvidia profile.
     
    • Like Like x 1
  3. johnnymat

    johnnymat

    Messages:
    229
    Ratings:
    +61
    Thank you very much for the information. I'll go ahead and fix it.