• "I've tried everything other than jumping out of a plane, but nothing gives you an adrenaline rush like racing a car." - Nigel Mansell
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rFactor 2 Dedicated Server

Discussion in 'rFactor 2' started by James Early, Aug 25, 2016.

  1. James Early

    James Early

    Messages:
    143
    Ratings:
    +42
    I used to host my own server with no problems but now that is a different story. I have portforwarded all the right ports, also I have set up the server correctly but when I click load track the data rate is always 0% up and 0% down. This has only started happening recently. I am on the steam version and I am running the latest build.

    Also how do I enable the getmod feature so that when anyone joins the mods are automatically installed for them? Thanks!
     
  2. Gijs van Elderen

    Gijs van Elderen
    Premium

    Messages:
    4,569
    Ratings:
    +2,356
    If the server has no clients. Data rate is 0%. That's normal.

    Getmod is enabled with mods that have a get mod link. ISI content and quality 3rd party mods already have a getmod link. URD is payware so it doesn't have a get mod link.

    For mods without a get mod link: http://isiforums.net/f/showthread.php/19702-GetMod-Manager
     
  3. James Early

    James Early

    Messages:
    143
    Ratings:
    +42
    My server never appears on the server list either so is there a fix for that?
     
  4. Marcel Offermans

    Marcel Offermans
    Staff

    Messages:
    637
    Ratings:
    +742
  5. James Early

    James Early

    Messages:
    143
    Ratings:
    +42
    I just launched the server again yesterday and everything works perfect now, I have changed nothing at all so that is quite strange...
     
    • Like Like x 1
  6. Gijs van Elderen

    Gijs van Elderen
    Premium

    Messages:
    4,569
    Ratings:
    +2,356
    Did you reboot your PC?
    If you don't have a static IP adress.
    You'll need to adjust the IP in the port forwarding again.

    If you have a dynamic IP: your IP might change. BTW: I'm talking about your local network IP.
     
    Last edited: Sep 7, 2016