1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Featured rFactor 2: Build 770 Now Available!

Discussion in 'rFactor 2' started by Stefan Woudenberg, Jul 1, 2014.

  1. Stefan Woudenberg

    Stefan Woudenberg
    Premium Member

    Formula 3_5.jpg
    Image Space Incorporated released a new build of rFactor 2 adding more features and improvements to the popular PC racing simulator.

    Highlights of this build are improved memory usage in 32bit. The RealRoad received some major tweaks and is no longer accelerated (unless you want it to be). Flag rules without disqualification as an option. Lots of AI improvements. New matchmaker technology in the back end. Enhanced plugin reporting. Modding tool changes, and various fixes and tweaks.

    Of course a new demo exe is available as well. Plus the experimental 64bit exes are available to openly test.

    Find the full changelog and download link below.

    • Fixed sun block bug which caused inconsistent occluder values.
    • Fixed a bug where HUD textures refuse to load.
    • Experimental 64 Bit builds added. Manual rename of 64 bit executables to 32 bit names required so the launcher can successfully start 64 bit executables.
    • Upgraded to latest version (9.3k) of Miles Sound System.
    • Updated projects to latest OpenSSL (1.0.1h)
    • Support added for gear-specific rev limit offsets.
    • Added additional Flag Rules option “Full w/o DQ”.
    • Eliminated race condition that could cause race rejoin to fail.
    • Added RealRoad timescale multiplier to control how fast the dynamic road changes conditions.
    • Added the ability to control vehicle- and tire-specific effects on RealRoad.
    • Optimized memory usage.
    • Fixed thread safety issue that could produce crash when crossing finish line while recording a best path.
    • Fixed a problem where remote vehicles might appear to have brakes on all the time (and no steering, either) while viewing from the monitor.
    • Fixed issue where leftover RealRoad events could be applied in the wrong session.
    • Fixed inconsistent writing of config.ini if installed to write-restricted path.
    • Improved collision with temp cars.
    • Fix reporting of anti-stall to plugins.
    • Potential fix for exiting game while skin transfer is unfinished.
    • Needing to update car components will not overwrite any existing parameters from talent/vehicle rcd files. Will only add unique parameters.
    • Fix problem where you sometimes get a brief blast of vehicles sounds on subsequent track loads.
    • Fixed issue if server was password protected it would not verify server content was installed on client.
    • Added OpenMP to Mod Mode and Dev builds (improves speed of TTool).
    • Added a dev mode AIW editor options to move selected waypoint’s selected path so that the next waypoint (or previous) matches the speed of the waypoint 2 spaces in front (or behind).
    • Corrected problem where +ptool and +ttool wouldn’t start up properly when using SDK.
    • Attempt to use AVX (if available) in 64-bit TTool.
    • Fixed double screenshots in TTool.
    • Plugins will need to be built in 32-bit and 64-bit versions. Please add “_x64″ to the names of the 64-bit version for easier identification, otherwise anybody with a 32-bit version of Windows will get an annoying popup.
    • Made plugin functions RenderScreenBeforeOverlays() and RenderScreenAfterOverlays() always work in the UI, so that plugins can identify the options page.
    UI / HUD / Options:
    • Added new gizmo action to clear multiplayer password.
    • Possible fix for HUDs picking up & using unrelated but identically named assets.
    • Sync up RealRoad on new clients at an accelerated pace.
    • Changed upload/download speed variable so that higher rates could be set in the dedicated server.
    • Initialize newly-joined clients to a basic RealRoad value such that they can’t gain an advantage over other clients.
    • Fixed multiple players in dedicated server startup dialog.
    • Fix controller auto-detect on first startup. Hopefully without causing that no-keyboard problem on Win8 whose fix broke this.
    • Output FFB value to plugins even if no FFB devices are detected.
    • Added checks to be sure only real AIs can talk and request pits.
    • Improvements to superspeedway AI.
    • Added AI control to PhysicsOptionsV01 in plugin interface.
    • Now doing limited loading of rcd files from location components so that track builders can specify new track specific driving lines of known 3rd party cars without.
    • Fixed AI cars swerving on formation lap skip and transition from formation lap to race.
    • Removed unnecessary AI braking prediction that had them tapping the brakes needlessly.
    • Reset “add AI” menu when leaving page
    Download the new build here.
    • Like Like x 11
    • Beer Beer x 1
  2. Thanks!
  3. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    to get it to work in 64 mode :)

    Experimental 64 Bit builds added. Manual rename of 64 bit executables to 32 bit names required so the launcher can successfully start 64 bit executables.

    if you dont do it it will still run in 32 bit

    loads up so quick :thumbsup::thumbsup:

    all plugins dont work any more and have to be remade in the 64 bit version:(
    gid hud track map etc.
    • Beer Beer x 1
  4. Delete
  5. Eric Bergeron

    Eric Bergeron
    Premium Member

  6. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    in the Core folder you will now see 2x .rFactor2 .exe and 2x rFactor2 Dedicated .exe

    keep the 64 bit ones and take out the old ones, then rename the 64 bit ones the same as the ones you have got rid off.

    Only do this if you have a 64 bit operating system,
    you should see a difference in the loading time.. click and it appears.. really quick now,,WOW
    you can also check if it working once the game is up and running by looking in your task manager.
    look in processes rfactor2.exe has now lost the *32 on the end
    Last edited: Jul 2, 2014
    • Like Like x 2
    • Beer Beer x 2
  7. Bez

    All the gear, no idea... Premium Member

    :cool: ahhh yeah!
  8. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member


    you got it working then,
    did you understand my instructions, :)
  9. Yea, I just didn't take the time to look in the game folder before I posted. If I had done that, I would have seen the 64 bit exe.
  10. Performance is worse for me with this new build. My previous graphic settings were maintaining 60fps, with this new build changing nothing else, I'm getting high 40's and low 50's.
  11. Phil Shillitoe

    Phil Shillitoe
    Premium Member

    Super quick loading and glad to say no performance issues here :)...but missing map/gid hud etc. Didn't realised that I relied on the plugins so much...until now :coffee:
  12. Damn sure drives great though. I didn't really see many changes related to FFB, but it sure does feel good.
  13. Hm I can't select any rear road options in single player. It says only "green" for practice and I don't have any sliders. Does anybody know a solution for this already?
  14. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    Go on track do some laps, go back, and see if you can choose "auto-saved" for practice session.
  15. Ok but where are my setups?! Seriously how did they brake something that worked o_O
  16. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    They should be in the userdata/player/settings folder... :). Check if they are still there.

    Edit: have you done a new install or the update in the rF2 launcher?
    Last edited: Jul 2, 2014
  17. So all my setups are where I've left them yesterday but somehow they do not appear ingame. Trackmap doesn't work also. Yes I installed the new update via launcher and now my game seems to be broken... No comment... It was supposed to be an update for better...

    PS: OK real road is fixed now, you need to change weather to "scripted" and it's ok. The problems with setups and plugins still appear - no setups ingame, no plugins working.
    Last edited: Jul 2, 2014
  18. James Maskell

    James Maskell
    "Remember the name! Tommy Vercetti!"

    Im guessing you didn't change over to 64bit. So your existing plugins should be fine, so thats strange. Thanks for the fix for the real road problem, i was stuck with that.
  19. So trackmap works for 32 bit version only, all plugins do not work with 64 bit. Setups are still missing ingame, I'm guessing the game just saves them in a different location but I have no clue where. It's interesting cause I saved a setup ingame and when I try to search it with windows seach I just can't find it anywhere. The file is just missing.
  20. James Maskell

    James Maskell
    "Remember the name! Tommy Vercetti!"

    Yeah you have to update your plugins with 64bit ones. I dont think trackmap has been updated yet unfortunately. Not being able to find the setup files is very strange, i haven't had any problems with missing setups and i dont really know where to start. I don't see why it would all of a sudden change the location of setups. :O_o: